[SECURITY] [DSA 3343-1] twig security update

2015-10-26T00:00:00
ID SECURITYVULNS:DOC:32648
Type securityvulns
Reporter Securityvulns
Modified 2015-10-26T00:00:00

Description


Debian Security Advisory DSA-3343-1 security@debian.org https://www.debian.org/security/ Sebastien Delafond August 26, 2015 https://www.debian.org/security/faq


Package : twig

James Kettle, Alain Tiemblo, Christophe Coevoet and Fabien Potencier discovered that twig, a templating engine for PHP, did not correctly process its input. End users allowed to submit twig templates could use specially crafted code to trigger remote code execution, even in sandboxed templates.

For the stable distribution (jessie), this problem has been fixed in version 1.16.2-1+deb8u1.

For the testing (stretch) and unstable (sid) distributions, this problem has been fixed in version 1.20.0-1.

We recommend that you upgrade your twig packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org