CVE-2015-6576: Bamboo - Deserialisation resulting in remote code execution

2015-10-26T00:00:00
ID SECURITYVULNS:DOC:32599
Type securityvulns
Reporter Securityvulns
Modified 2015-10-26T00:00:00

Description

Note: the current version of this advisory can be found at https://confluence.atlassian.com/x/Hw7RLg .

CVE ID: CVE-2015-6576 Product: Bamboo. Affected Bamboo product versions: * 2.2 <= version < 5.8.5 * 5.9.0 <= version < 5.9.7

Summary: This advisory discloses a critical severity security vulnerability that was introduced in version 2.2 of Bamboo. Versions of Bamboo starting with 2.2 before 5.8.5 (the fixed version for 5.8.x) and from 5.9.0 before 5.9.7 (the fixed version for 5.9.x) are vulnerable.

Atlassian Cloud instances have already been upgraded to a version of Bamboo which does not have the issue described on this page.

Customers who have upgraded Bamboo to version 5.8.5 or version 5.9.7 are not affected.

Customers who have downloaded and installed Bamboo >= 2.2 less than 5.8.5 (the fixed version for 5.8.x): Please upgrade your Bamboo installations immediately to fix this vulnerability.

Customers who have downloaded and installed Bamboo >= 5.9.0 less than 5.9.7 (the fixed version for 5.9.x): Please upgrade your Bamboo installations immediately to fix this vulnerability.

Severity: Atlassian rates the severity level of this vulnerability as critical, according to the scale published in our Atlassian severity levels. The scale allows us to rank a severity as critical, high, moderate, or low. This is an independent assessment and you should evaluate its applicability to your own IT environment.

Description: Bamboo had a resource that deserialised arbitrary user input without restriction. Attackers can use this vulnerability to execute Java code of their choice on systems that have a vulnerable version of Bamboo. To exploit this issue, attackers need to be able to access the Bamboo web interface.

All versions of Bamboo from 2.2 before 5.8.5 (the fixed version for 5.8.x) and from 5.9.0 before 5.9.7 (the fixed version for 5.9.x) are affected by this vulnerability. This issue can be tracked here: https://jira.atlassian.com/browse/BAM-16439

Acknowledgements: We would like to credit Matthias Kaiser of Code White for reporting this issue to Atlassian.

Fix: We have taken the follow steps to address this issue: 1. Released Bamboo version 5.9.7 that contains a fix for this issue. 2. Released Bamboo version 5.8.5 that contains a fix for this issue.

Remediation: Upgrade Bamboo to version 5.9.7 or higher.

If you are running Bamboo 5.8.x and cannot upgrade to bamboo 5.9.X, then upgrade to version 5.8.5.

For a full description of the latest version of Bamboo, see the release notes found at https://confluence.atlassian.com/display/BAMBOO/Bamboo+releases. You can download the latest version of Bamboo from the download centre found at https://www.atlassian.com/software/bamboo/download.

Support: If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/ .

-- David Black / Security Engineer.