[SECURITY] [DSA 3376-1] chromium-browser security update

2015-10-25T00:00:00
ID SECURITYVULNS:DOC:32571
Type securityvulns
Reporter Securityvulns
Modified 2015-10-25T00:00:00

Description

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA512


Debian Security Advisory DSA-3376-1 security@debian.org https://www.debian.org/security/ Michael Gilbert October 20, 2015 https://www.debian.org/security/faq


Package : chromium-browser CVE ID : CVE-2015-1303 CVE-2015-1304 CVE-2015-6755 CVE-2015-6756 CVE-2015-6757 CVE-2015-6758 CVE-2015-6759 CVE-2015-6760 CVE-2015-6761 CVE-2015-6762 CVE-2015-6763

Several vulnerabilities have been discovered in the chromium web browser.

CVE-2015-1303

Mariusz Mlynski discovered a way to bypass the Same Origin Policy
in the DOM implementation.

CVE-2015-1304

Mariusz Mlynski discovered a way to bypass the Same Origin Policy
in the v8 javascript library.

CVE-2015-6755

Mariusz Mlynski discovered a way to bypass the Same Origin Policy
in blink/webkit.

CVE-2015-6756

A use-after-free issue was found in the pdfium library.

CVE-2015-6757

Collin Payne found a use-after-free issue in the ServiceWorker
implementation.

CVE-2015-6758

Atte Kettunen found an issue in the pdfium library.

CVE-2015-6759

Muneaki Nishimura discovered an information leak.

CVE-2015-6760

Ronald Crane discovered a logic error in the ANGLE library
involving lost device events.

CVE-2015-6761

Aki Helin and Khalil Zhani discovered a memory corruption issue in
the ffmpeg library.

CVE-2015-6762

Muneaki Nishimura discovered a way to bypass the Same Origin Policy
in the CSS implementation.

CVE-2015-6763

The chrome 46 development team found and fixed various issues
during internal auditing.  Also multiple issues were fixed in
the v8 javascript library, version 4.6.85.23.

For the stable distribution (jessie), these problems have been fixed in version 46.0.2490.71-1~deb8u1.

For the testing (stretch) and unstable (sid) distributions, these problems have been fixed in version 46.0.2490.71-1.

We recommend that you upgrade your chromium-browser packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org -----BEGIN PGP SIGNATURE----- Version: GnuPG v1

iQQcBAEBCgAGBQJWJwEHAAoJELjWss0C1vRzawcf/2VLLVk0XIIvX6TajYjXf+O+ MFWcbB/EVhdMcF3JTekflcv/LRbYq2TnqWPb0W/AM7hOCWbk4mgD6stbe7l/j2QW 0o3FZkL7pCJL72kvXPxGdvHFs+Qhemrd8AAS9nIqWnqGGcTSC2IdFOLEXec77an7 pvQCjT6g/gBb2ywbip7Pv9G3n6oMGTwcBAklm+7So6OjZZpcFrfEqkv8a9zgqH6B iSaoMws7iYaBisKn/5ot91lLbDIuRkSX8RfbG7b6s2v9WiN8bzPZUUJYpsBxf7m/ BY7bZYqpMhjDOEMQJ8NedgHnLabjpBXJi7gn444eHS9VGDgEBtduCJhUQ7oqq/Bl PEZdBardMDwmV/DSDKGH0WHsAzmDInk5Bd9/yqNspIl0azYaEownEg5mQeU06G3Z oIXX6l+hYzMRrLPEachAdHUyz7PhYU9X5uPUDtpkaGuJsylh2vyW5pGTumhdf/nt ae6VRy5p57HD7atQc+lesNUbO5225QFwaBRf3t/e/nHyYWZHZS9hFWyPha1EGpEy wuYYnjhSTh/kThEjDkROz3ayNod6NRJ8BkUfsgoj+Ui1cUASFdJtih/S2k70YM1e mvq5P3kHEUrYVvHpM+m9ZyzbwcluQKS4he3WGlSTEAyS8BIoohZb6QQO+lTOYo2/ qjqBYRhe2GMlW8AYynjQsSdQcHpBxX+qH4kS5+C5swH7c7NogZo7KWdPENW8LQgP irXB/u+RMbje5X3Qec/pG85vX196r+UUUQNV2ZFIlXbqgKGHWEeJ3+cNulJE2xet XI5pthBmzxEG0Xpw2OOkjkpRg0W7C0QBlNRbCqsk6KhobhxapoqNmkb2BTxbAs8r wqrL8R+c0JM0dYH+PuZeZmOyL3XJxHU9cCJUn2f0oCrBKLLSG9gj0v1a5ntqSEjH A00PXcXq8IXXnIu+xXe6fU3RxcVY0YykKkZKkh003gRItOC45PBP3/gu3KRStNpB zz4iL2jq4uwEPPgWAGS9BQrDgWaRxDnJPuF0C+uwfdTPLclHSKLewWbgH2zPa5ff XV60fxw6PM3VyGO1lCfEOVoHHt1jtN9JlM14SuNLaC+y/jFqcVVJJOdqGKAjAqNk O7fep+G46EPkpy9zTeM+CuekDdU8lClq8caLEC03zQK0C+0QA50zCRxJ6yBzpr8+ DstSjRoqCJLPbFTpHtMK9MEcEXXOyw+9d7/wF9sexNMhq0ONGs0KNFPb+H4dSG+A LeYtlrgELMQYhWq2y4CB/5EKlljDY99axy/HyICfaRejcTPs6a6x7+vyrcoCcAAm Co9vSkn7QQJKB942+uOPmcd9bjDhboLrBARbN8q4Rk0tYMYUqa2mwnyYAnSq1xE= =OCPh -----END PGP SIGNATURE-----