[ MDVSA-2015:230 ] squid

2015-05-11T00:00:00
ID SECURITYVULNS:DOC:32016
Type securityvulns
Reporter Securityvulns
Modified 2015-05-11T00:00:00

Description

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1


Mandriva Linux Security Advisory MDVSA-2015:230 http://www.mandriva.com/en/support/security/


Package : squid Date : May 6, 2015 Affected: Business Server 2.0


Problem Description:

Updated squid packages fix security vulnerability:

Squid configured with client-first SSL-bump does not correctly validate X509 server certificate domain / hostname fields (CVE-2015-3455).


References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3455 http://advisories.mageia.org/MGASA-2015-0191.html


Updated Packages:

Mandriva Business Server 2/X86_64: 1b42519307a1a9656d770c16a52cc255 mbs2/x86_64/squid-3.3.14-1.mbs2.x86_64.rpm e265cc1b9286427d303db2d7ce8a9e5d mbs2/x86_64/squid-cachemgr-3.3.14-1.mbs2.x86_64.rpm 2218b2d6b499bbf470798805c774a5ea mbs2/SRPMS/squid-3.3.14-1.mbs2.src.rpm


To upgrade automatically use MandrivaUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/en/support/security/advisories/

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com


Type Bits/KeyID Date User ID pub 1024D/22458A98 2000-07-10 Mandriva Security Team <security*mandriva.com> -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFVSfQ6mqjQ0CJFipgRAnnaAJoCpgp0yT4RqQhTyCsfUCj9HflFVACeNtuz hsuApo5rskLRKadA81hW0E8= =oIlM -----END PGP SIGNATURE-----