[USN-2497-1] NTP vulnerabilities

2015-02-11T00:00:00
ID SECURITYVULNS:DOC:31709
Type securityvulns
Reporter Securityvulns
Modified 2015-02-11T00:00:00

Description

========================================================================== Ubuntu Security Notice USN-2497-1 February 09, 2015

ntp vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary:

Several security issues were fixed in NTP.

Software Description: - ntp: Network Time Protocol daemon and utility programs

Details:

Stephen Roettger, Sebastian Krahmer, and Harlan Stenn discovered that NTP incorrectly handled the length value in extension fields. A remote attacker could use this issue to possibly obtain leaked information, or cause the NTP daemon to crash, resulting in a denial of service. (CVE-2014-9297)

Stephen Roettger discovered that NTP incorrectly handled ACLs based on certain IPv6 addresses. (CVE-2014-9298)

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.10: ntp 1:4.2.6.p5+dfsg-3ubuntu2.14.10.2

Ubuntu 14.04 LTS: ntp 1:4.2.6.p5+dfsg-3ubuntu2.14.04.2

Ubuntu 12.04 LTS: ntp 1:4.2.6.p3+dfsg-1ubuntu3.3

Ubuntu 10.04 LTS: ntp 1:4.2.4p8+dfsg-1ubuntu2.3

In general, a standard system update will make all the necessary changes.

References: http://www.ubuntu.com/usn/usn-2497-1 CVE-2014-9297, CVE-2014-9298

Package Information: https://launchpad.net/ubuntu/+source/ntp/1:4.2.6.p5+dfsg-3ubuntu2.14.10.2 https://launchpad.net/ubuntu/+source/ntp/1:4.2.6.p5+dfsg-3ubuntu2.14.04.2 https://launchpad.net/ubuntu/+source/ntp/1:4.2.6.p3+dfsg-1ubuntu3.3 https://launchpad.net/ubuntu/+source/ntp/1:4.2.4p8+dfsg-1ubuntu2.3

-- ubuntu-security-announce mailing list ubuntu-security-announce@lists.ubuntu.com Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce