[USN-2362-1] Bash vulnerability

2014-09-25T00:00:00
ID SECURITYVULNS:DOC:31100
Type securityvulns
Reporter Securityvulns
Modified 2014-09-25T00:00:00

Description

========================================================================== Ubuntu Security Notice USN-2362-1 September 24, 2014

bash vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary:

Bash allowed bypassing environment restrictions in certain environments.

Software Description: - bash: GNU Bourne Again SHell

Details:

Stephane Chazelas discovered that Bash incorrectly handled trailing code in function definitions. An attacker could use this issue to bypass environment restrictions, such as SSH forced command environments.

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 LTS: bash 4.3-7ubuntu1.1

Ubuntu 12.04 LTS: bash 4.2-2ubuntu2.2

Ubuntu 10.04 LTS: bash 4.1-2ubuntu3.1

In general, a standard system update will make all the necessary changes.

References: http://www.ubuntu.com/usn/usn-2362-1 CVE-2014-6271

Package Information: https://launchpad.net/ubuntu/+source/bash/4.3-7ubuntu1.1 https://launchpad.net/ubuntu/+source/bash/4.2-2ubuntu2.2 https://launchpad.net/ubuntu/+source/bash/4.1-2ubuntu3.1

-- ubuntu-security-announce mailing list ubuntu-security-announce@lists.ubuntu.com Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce