[USN-2279-1] Transmission vulnerability

2014-07-21T00:00:00
ID SECURITYVULNS:DOC:30930
Type securityvulns
Reporter Securityvulns
Modified 2014-07-21T00:00:00

Description

========================================================================== Ubuntu Security Notice USN-2279-1 July 16, 2014

transmission vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 13.10
  • Ubuntu 12.04 LTS

Summary:

Transmission could be made to crash or run programs if it received specially crafted network traffic.

Software Description: - transmission: lightweight BitTorrent client

Details:

Ben Hawkes discovered that Transmission incorrectly handled certain peer messages. A remote attacker could use this issue to cause a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 LTS: transmission-common 2.82-1.1ubuntu3.1

Ubuntu 13.10: transmission-common 2.82-0ubuntu1.1

Ubuntu 12.04 LTS: transmission-common 2.51-0ubuntu1.4

After a standard system update you need to restart Transmission to make all the necessary changes.

References: http://www.ubuntu.com/usn/usn-2279-1 CVE-2014-4909

Package Information: https://launchpad.net/ubuntu/+source/transmission/2.82-1.1ubuntu3.1 https://launchpad.net/ubuntu/+source/transmission/2.82-0ubuntu1.1 https://launchpad.net/ubuntu/+source/transmission/2.51-0ubuntu1.4

-- ubuntu-security-announce mailing list ubuntu-security-announce@lists.ubuntu.com Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce