XSS and FPD vulnerabilities in WPtouch and WPtouch Pro for WordPress

2013-09-09T00:00:00
ID SECURITYVULNS:DOC:29744
Type securityvulns
Reporter Securityvulns
Modified 2013-09-09T00:00:00

Description

Hello 3APA3A!

I want to inform you about vulnerabilities in WPtouch and WPtouch Pro plugins for WordPress.

These are Cross-Site Scripting and Full path disclosure vulnerabilities. These XSS holes are in ZeroClipboard.swf, which is used in the plugin. In February I wrote about Cross-Site Scripting vulnerabilities in ZeroClipboard (http://seclists.org/fulldisclosure/2013/Feb/103) and in multiple web applications.


Affected products:

Vulnerable are all versions of plugin WPtouch and WPtouch Pro.


Affected vendors:

BraveNewCode http://www.bravenewcode.com


Details:

Cross-Site Scripting (WASC-08):

XSS via id parameter and XSS via copying payload into clipboard (as described in my advisory).

http://site/wp-content/plugins/wptouch-pro/admin/js/ZeroClipboard.swf?id=\%22))}catch(e){}if(!self.a)self.a=!alert(document.cookie)//&width&height

Full path disclosure (WASC-13):

http://site/wp-content/plugins/wptouch/wptouch.php

http://site/wp-content/plugins/wptouch-pro/wptouch-pro.php

And other php-files in plugin folder and subfolders.

http://site/wp-content/plugins/wptouch/error_log

http://site/wp-content/plugins/wptouch-pro/error_log

In plugin folder and subfolders (at web sites where showing errors is off and they are saving into error_log).


Timeline:

2013.02.18 - informed old and new developers of ZeroClipboard. 2013.04.17 - announced at my site and later informed developers of WPtouch and WPtouch Pro. 2013.08.03 - disclosed at my site (http://websecurity.com.ua/6454/).

Best wishes & regards, MustLive Administrator of Websecurity web site http://websecurity.com.ua