[ANN] Struts 2.3.14.1 GA (fast track | security)

2013-07-15T00:00:00
ID SECURITYVULNS:DOC:29595
Type securityvulns
Reporter Securityvulns
Modified 2013-07-15T00:00:00

Description

The Apache Struts group is pleased to announce that Struts 2.3.14.1 is available as a "General Availability" release. The GA designation is our highest quality grade.

Apache Struts 2 is an elegant, extensible framework for creating enterprise-ready Java web applications. The framework is designed to streamline the full development cycle, from building, to deploying, to maintaining applications over time.

Two security issues were solved with this release: * Showcase app vulnerability allows remote command execution * A vulnerability, present in the includeParams attribute of the URL and Anchor Tag, allows remote command execution

All developers are strongly advised to update existing Struts 2 applications to Struts 2.3.14.1.

Struts 2.3.14.1 is available in a full distribution or as separate library, source, example and documentation distributions, from the releases page. The release is also available through the central Maven repository under Group ID "org.apache.struts". The release notes are available online.

The 2.3.x series of the Apache Struts framework has a minimum requirement of the following specification versions: Servlet API 2.4, JSP API 2.0, and Java 5.

Should any issues arise with your use of any version of the Struts framework, please post your comments to the user list, and, if appropriate, file a tracking ticket.

  • The Apache Struts group.

Kind regards -- Lukasz