I want to warn you about multiple security vulnerabilities in plugin Organizer for WordPress. This is the first in series of advisories concerning vulnerabilities in this plugin.
These are Cross-Site Scripting (reflected and persistent) and Full path disclosure vulnerabilities.
Vulnerable are Organizer 1.2.1 and previous versions.
As answered me the developer of the plugin, he doesn't support it anymore and will no be fixing multiple vulnerabilities in it, about which I've informed him (these and many other vulnerabilities).
XSS (Persistent) (WASC-08):
POST request at page http://site/wp-admin/admin.php?page=organizer/page/users.php <script>alert(document.cookie)</script> In field: "File extensions allowed".
Code will execute at the page users.php of the plugin.
Full path disclosure (WASC-13):
2012.04.14 - announced at my site (http://websecurity.com.ua/5782/). 2012.04.15 - informed the developer. 2012.04.17 - the developer answered, that he didn't support the plugin anymore. 2012.04.21 - disclosed at my site.
Best wishes & regards, MustLive Administrator of Websecurity web site http://websecurity.com.ua