Lucene search

K
securityvulnsSecurityvulnsSECURITYVULNS:DOC:26055
HistoryApr 05, 2011 - 12:00 a.m.

HTB22912: Multiple SQL Injections in Eleanor CMS

2011-04-0500:00:00
vulners.com
72

Vulnerability ID: HTB22912
Reference: http://www.htbridge.ch/advisory/multiple_sql_injections_in_eleanor_cms.html
Product: Eleanor CMS
Vendor: Eleanor CMS ( http://eleanor-cms.ru/ )
Vulnerable Version: rc5
Vendor Notification: 22 March 2011
Vulnerability Type: SQL Injection
Status: Fixed by Vendor
Risk level: High
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details:
The vulnerability exists due to failure in the "download.php" & "upload.php" scripts to properly sanitize user-supplied input in "module" variable.
Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.

The following PoC is available:

[code]
http://[host]/download.php?module=1%27
http://[host]/upload.php?module=1%27
[/code]
Solution: Upgrade to the most recent version