HTB22850: SQL Injection in WP Forum Server wordpress plugin

2011-02-24T00:00:00
ID SECURITYVULNS:DOC:25780
Type securityvulns
Reporter Securityvulns
Modified 2011-02-24T00:00:00

Description

Vulnerability ID: HTB22850 Reference: http://www.htbridge.ch/advisory/sql_injection_in_wp_forum_server_wordpress_plugin.html Product: WP Forum Server wordpress plugin Vendor: VastHTML ( http://lucidcrew.com/ ) Vulnerable Version: 1.6.5 Vendor Notification: 10 February 2011 Vulnerability Type: SQL Injection Risk level: High Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details: The vulnerability exists due to failure in the "/wp-content/plugins/forum-server/feed.php" script to properly sanitize user-supplied input in "topic" variable. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.

The following PoC is available:

http://[host]/wp-content/plugins/forum-server/feed.php?topic=1%20union%20select%20version%28%29%20--