[ MDVSA-2010:092 ] cacti

2010-05-11T00:00:00
ID SECURITYVULNS:DOC:23802
Type securityvulns
Reporter Securityvulns
Modified 2010-05-11T00:00:00

Description

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1


Mandriva Linux Security Advisory MDVSA-2010:092 http://www.mandriva.com/security/


Package : cacti Date : May 6, 2010 Affected: Corporate 4.0, Enterprise Server 5.0


Problem Description:

A vulnerability has been found and corrected in cacti:

SQL injection vulnerability in templates_export.php in Cacti 0.8.7e and earlier allows remote attackers to execute arbitrary SQL commands via the export_item_id parameter (CVE-2010-1431).

Additionally cacti has been upgraded to 0.8.7e for Corporate Server 4.

The updated packages have been patched to correct this issue.


References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-1431


Updated Packages:

Corporate 4.0: 2f3d03d69004d2b28558482d10e216ea corporate/4.0/i586/cacti-0.8.7e-0.1.20060mlcs4.noarch.rpm f0e0ff07e7ac616ebff35462b5ffa50f corporate/4.0/SRPMS/cacti-0.8.7e-0.1.20060mlcs4.src.rpm

Corporate 4.0/X86_64: 86170ffeee1bc83e01a3b77a6b40f329 corporate/4.0/x86_64/cacti-0.8.7e-0.1.20060mlcs4.noarch.rpm f0e0ff07e7ac616ebff35462b5ffa50f corporate/4.0/SRPMS/cacti-0.8.7e-0.1.20060mlcs4.src.rpm

Mandriva Enterprise Server 5: 2acb4fdcbf42d3fcd3741a5a3512dd4b mes5/i586/cacti-0.8.7e-11.1mdvmes5.1.noarch.rpm 3d72b27fdf373d02a966292cd543fe76 mes5/SRPMS/cacti-0.8.7e-11.1mdvmes5.1.src.rpm

Mandriva Enterprise Server 5/X86_64: ec13040e7536fb994b1b3126cdd21daa mes5/x86_64/cacti-0.8.7e-11.1mdvmes5.1.noarch.rpm 3d72b27fdf373d02a966292cd543fe76 mes5/SRPMS/cacti-0.8.7e-11.1mdvmes5.1.src.rpm


To upgrade automatically use MandrivaUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com


Type Bits/KeyID Date User ID pub 1024D/22458A98 2000-07-10 Mandriva Security Team <security*mandriva.com> -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFL4wRRmqjQ0CJFipgRAnopAKCKzKP6ETA7CehR2ndSsCh48xVmbACfV2b3 I/4h+vy4DxQgtjU2nDIV1og= =Mn+A -----END PGP SIGNATURE-----