[ GLSA 200807-16 ] Python: Multiple vulnerabilities

2008-08-01T00:00:00
ID SECURITYVULNS:DOC:20272
Type securityvulns
Reporter Securityvulns
Modified 2008-08-01T00:00:00

Description


Gentoo Linux Security Advisory GLSA 200807-16


                                        http://security.gentoo.org/

Severity: Normal Title: Python: Multiple vulnerabilities Date: July 31, 2008 Bugs: #230640, #232137 ID: 200807-16


Synopsis

Multiple vulnerabilities in Python may allow for the execution of arbitrary code.

Background

Python is an interpreted, interactive, object-oriented programming language.

Affected packages

-------------------------------------------------------------------
 Package          /  Vulnerable  /                      Unaffected
-------------------------------------------------------------------

1 dev-lang/python < 2.5.2-r6 *>= 2.4.4-r14 >= 2.5.2-r6

Description

Multiple vulnerabilities were discovered in Python:

  • David Remahl of Apple Product Security reported several integer overflows in core modules such as stringobject, unicodeobject, bufferobject, longobject, tupleobject, stropmodule, gcmodule, mmapmodule (CVE-2008-2315).

  • David Remahl of Apple Product Security also reported an integer overflow in the hashlib module, leading to unreliable cryptographic digest results (CVE-2008-2316).

  • Justin Ferguson reported multiple buffer overflows in unicode string processing that only affect 32bit systems (CVE-2008-3142).

  • The Google Security Team reported multiple integer overflows (CVE-2008-3143).

  • Justin Ferguson reported multiple integer underflows and overflows in the PyOS_vsnprintf() function, and an off-by-one error when passing zero-length strings, leading to memory corruption (CVE-2008-3144).

Impact

A remote attacker could exploit these vulnerabilities in Python applications or daemons that pass user-controlled input to vulnerable functions. Exploitation might lead to the execution of arbitrary code or a Denial of Service. Vulnerabilities within the hashlib might lead to weakened cryptographic protection of data integrity or authenticity.

Workaround

There is no known workaround at this time.

Resolution

All Python 2.4 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/python-2.4.4-r14&quot;

All Python 2.5 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/python-2.5.2-r6&quot;

Please note that Python 2.3 is masked since June 24, and we will not be releasing updates to it. It will be removed from the tree in the near future.

References

[ 1 ] CVE-2008-2315 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2315 [ 2 ] CVE-2008-2316 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2316 [ 3 ] CVE-2008-3142 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3142 [ 4 ] CVE-2008-3143 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3143 [ 5 ] CVE-2008-3144 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3144

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200807-16.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2008 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5