Vulnerability in Moodle

2007-07-02T00:00:00
ID SECURITYVULNS:DOC:17391
Type securityvulns
Reporter Securityvulns
Modified 2007-07-02T00:00:00

Description

Здравствуйте 3APA3A!

Сообщаю вам о найденной мною Cross-Site Scripting уязвимости в Moodle.

Уязвимость в параметре search в скрипте index.php.

XSS:

http://host/user/index.php?contextid=4&roleid=0&id=2&group=&perpage=20&search=%22style=xss:expression(alert(document.cookie))%20

Данный PoC предназначен для IE (для работы в разных браузерах, можно использовать onMouseOver или другой вектор).

Уязвима версия Moodle 1.7.1 и предыдущие (потенциально могут быть уязвимыми и последующие версии системы).

Дополнительная информация о данной уязвимости у меня на сайте: http://websecurity.com.ua/1045/

Best wishes & regards, MustLive Администратор сайта http://websecurity.com.ua