[ MDKSA-2007:019 ] - Updated pdftohtml packages fix crafted pdf file vulnerability

2007-01-19T00:00:00
ID SECURITYVULNS:DOC:15756
Type securityvulns
Reporter Securityvulns
Modified 2007-01-19T00:00:00

Description

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1


Mandriva Linux Security Advisory MDKSA-2007:019 http://www.mandriva.com/security/


Package : pdftohtml Date : January 18, 2007 Affected: 2006.0, 2007.0


Problem Description:

The Adobe PDF specification 1.3, as implemented by xpdf 3.0.1 patch 2, kpdf in KDE before 3.5.5, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.

The updated packages have been patched to correct this problem.


References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0104


Updated Packages:

Mandriva Linux 2006.0: 8c5528f9018b261887538d3dac6ce8bb 2006.0/i586/pdftohtml-0.36-2.2.20060mdk.i586.rpm 45b30c0ca9d4179097948e37e5cccb85 2006.0/SRPMS/pdftohtml-0.36-2.2.20060mdk.src.rpm

Mandriva Linux 2006.0/X86_64: 784d32b1f0106db8b9ec1e5ad2bf3f7f 2006.0/x86_64/pdftohtml-0.36-2.2.20060mdk.x86_64.rpm 45b30c0ca9d4179097948e37e5cccb85 2006.0/SRPMS/pdftohtml-0.36-2.2.20060mdk.src.rpm

Mandriva Linux 2007.0: e76274c7e22d68f38a9e1ae97494f71f 2007.0/i586/pdftohtml-0.36-5.1mdv2007.0.i586.rpm d52fb3abbff1579eb3ca70aacac01273 2007.0/SRPMS/pdftohtml-0.36-5.1mdv2007.0.src.rpm

Mandriva Linux 2007.0/X86_64: 06be394049978fc5b4ecf512bc61d777 2007.0/x86_64/pdftohtml-0.36-5.1mdv2007.0.x86_64.rpm d52fb3abbff1579eb3ca70aacac01273 2007.0/SRPMS/pdftohtml-0.36-5.1mdv2007.0.src.rpm


To upgrade automatically use MandrivaUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com


Type Bits/KeyID Date User ID pub 1024D/22458A98 2000-07-10 Mandriva Security Team <security*mandriva.com> -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFr7TfmqjQ0CJFipgRAtRNAJ9xsaBrJx4c+xXnA7FYoHH1rTaBWACgkpFj q+qqAteSCHta5qNNTjQ3l9I= =PzqW -----END PGP SIGNATURE-----