[SA23608] OpenBSD "vga" Privilege Escalation Vulnerability

2007-01-05T00:00:00
ID SECURITYVULNS:DOC:15590
Type securityvulns
Reporter Securityvulns
Modified 2007-01-05T00:00:00

Description

TITLE: OpenBSD "vga" Privilege Escalation Vulnerability

SECUNIA ADVISORY ID: SA23608

VERIFY ADVISORY: http://secunia.com/advisories/23608/

CRITICAL: Less critical

IMPACT: Privilege escalation

WHERE: Local system

OPERATING SYSTEM: OpenBSD 4.0 http://secunia.com/product/12486/ OpenBSD 3.x http://secunia.com/product/100/

DESCRIPTION: A vulnerability has been reported in OpenBSD, which can be exploited by malicious, local users to gain escalated privileges.

The vulnerability is caused due to an input validation error in sys/dev/pci/vga_pci.c of "vga" (VGA graphics driver for wscons), which can be exploited to gain escalated privileges.

Successful exploitation may allow to gain root privileges, but requires that the kernel is compiled with "option PCIAGP" (by default only available for i386) and that the device is not AGP compatible.

The vulnerability is reported in OpenBSD 3.9 and 4.0. Other versions may also be affected.

SOLUTION: Apply patch.

OpenBSD 3.9: ftp://ftp.openbsd.org/pub/OpenBSD/patches/3.9/i386/017_agp.patch

OpenBSD 4.0: ftp://ftp.openbsd.org/pub/OpenBSD/patches/4.0/i386/007_agp.patch

PROVIDED AND/OR DISCOVERED BY: Reported by the vendor.

ORIGINAL ADVISORY: http://www.openbsd.org/errata.html#agp


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.