[Aria-Security Team] CentOS 4.2 i686 - WHM X v3.1.0 Cross-Site Scripting

2006-12-08T00:00:00
ID SECURITYVULNS:DOC:15335
Type securityvulns
Reporter Securityvulns
Modified 2006-12-08T00:00:00

Description

c#Aria-Security Team Advisory

<www.Aria-security.Com For English >

<www.Aria-Security.net For Persian >

Original Advisory:

http://www.aria-security.com/forum/showthread.php?t=44

-----------------------------------------------------------

Software: WebHost Manager (WHM)

Tested WHM X v3.1.0 (demo.cpanel.net)

Poc:

http://target:2086/scripts2/changeemail?domain=d[XSS]

http://target:2086/scripts2/limitbw?domain=[XSS]

http://target:2086/scripts2/dofeaturemanager?action=editfeature&feature=XSS

http://target::2086/scripts/rearrangeacct?domain=[XSS]

P.S : Attacker must be authenticated

Contact: Advisory@aria-security.net