[SA22050] MAXdev MD-Pro Cross-Site Scripting Vulnerability

2006-09-21T00:00:00
ID SECURITYVULNS:DOC:14379
Type securityvulns
Reporter Securityvulns
Modified 2006-09-21T00:00:00

Description

TITLE: MAXdev MD-Pro Cross-Site Scripting Vulnerability

SECUNIA ADVISORY ID: SA22050

VERIFY ADVISORY: http://secunia.com/advisories/22050/

CRITICAL: Less critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: MAXdev MD-Pro 1.x http://secunia.com/product/5663/

DESCRIPTION: A vulnerability has been reported in MAXdev MD-Pro, which can be exploited by malicious people to conduct cross-site scripting attacks.

Input passed to unspecified parameters is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

The vulnerability has been reported in version 1.0.76. Prior versions may also be affected.

SOLUTION: Apply patch. http://www.maxdev.com/Downloads-index-req-dldet-lid-497-ttitle-Security_fix_for_MDPro_1.076.phtml

PROVIDED AND/OR DISCOVERED BY: Masaki Kubo from JPCERT.

ORIGINAL ADVISORY: MAXdev: http://www.maxdev.com/Article605.phtml

JVN: http://jvn.jp/jp/JVN%2346630603/index.html


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.