[SA21787] Attachment Mod Attachment Script Insertion Vulnerability

2006-09-07T00:00:00
ID SECURITYVULNS:DOC:14188
Type securityvulns
Reporter Securityvulns
Modified 2006-09-07T00:00:00

Description

TITLE: Attachment Mod Attachment Script Insertion Vulnerability

SECUNIA ADVISORY ID: SA21787

VERIFY ADVISORY: http://secunia.com/advisories/21787/

CRITICAL: Less critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: Attachment Mod 2.x (module for phpBB) http://secunia.com/product/4371/

DESCRIPTION: A vulnerability has been reported in the Attachment Mod module for phpBB, which can be exploited by malicious people to conduct script insertion attacks.

Input passed in uploaded attachments is not properly verified before being used. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site when a specially crafted image is viewed directly in the Microsoft Internet Explorer browser.

SOLUTION: Update to version 2.4.5.

PROVIDED AND/OR DISCOVERED BY: Reported by the vendor.

ORIGINAL ADVISORY: http://sourceforge.net/project/shownotes.php?release_id=445469


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.