[SA21542] Wikepage "lng" Local File Inclusion Vulnerability

2006-08-25T00:00:00
ID SECURITYVULNS:DOC:14041
Type securityvulns
Reporter Securityvulns
Modified 2006-08-25T00:00:00

Description

TITLE: Wikepage "lng" Local File Inclusion Vulnerability

SECUNIA ADVISORY ID: SA21542

VERIFY ADVISORY: http://secunia.com/advisories/21542/

CRITICAL: Moderately critical

IMPACT: Exposure of sensitive information

WHERE: >From remote

SOFTWARE: Wikepage Opus 10 http://secunia.com/product/11682/

DESCRIPTION: Hessam-x has discovered a vulnerability in Wikepage, which can be exploited by malicious people to disclose sensitive information.

Input passed to the "lng" parameter in index.php is not properly verified before it is used to include files. This can be exploited to include arbitrary files from local resources.

Successful exploitation requires that "magic_quotes_gpc" is disabled.

The vulnerability has been confirmed in version Opus 10 2006.2a. Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly verified.

PROVIDED AND/OR DISCOVERED BY: Hessam-x

ORIGINAL ADVISORY: http://milw0rm.com/exploits/2252


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.