[SA21185] Sun Grid Engine Unspecified Buffer Overflow Vulnerability

2006-08-02T00:00:00
ID SECURITYVULNS:DOC:13726
Type securityvulns
Reporter Securityvulns
Modified 2006-08-02T00:00:00

Description


Hardcore Disassembler / Reverse Engineer Wanted!

Want to work with IDA and BinDiff? Want to write PoC's and Exploits?

Your nationality is not important. We will get you a work permit, find an apartment, and offer a relocation compensation package.

http://secunia.com/hardcore_disassembler_and_reverse_engineer/


TITLE: Sun Grid Engine Unspecified Buffer Overflow Vulnerability

SECUNIA ADVISORY ID: SA21185

VERIFY ADVISORY: http://secunia.com/advisories/21185/

CRITICAL: Less critical

IMPACT: Privilege escalation, DoS

WHERE: Local system

SOFTWARE: Sun Grid Engine (SGE) 6.x http://secunia.com/product/6943/ Sun Grid Engine (SGE) 5.x http://secunia.com/product/2666/

DESCRIPTION: A vulnerability has been reported in Sun N1 Grid Engine, which can be exploited by malicious, local users to cause a DoS (Denial of Service) or gain escalated privileges.

The vulnerability is caused due to an unspecified boundary error and can be exploited to cause a buffer overflow.

Successful exploitation crashes the qmaster or execd process and shuts down the grid service and may also allow execution of arbitrary code with escalated privileges.

SOLUTION: Apply patches.

-- SPARC Platform --

N1 Grid Engine 6.0 (32-bit Solaris): Apply patch 123037-01 or later.

N1 Grid Engine 6.0 (64-bit Solaris): Apply patch 123038-01 or later.

N1 Grid Engine 6.0 (32-bit Solaris) NON-Solaris Package format: Apply patch 123041-01 or later.

N1 Grid Engine 6.0 (64-bit Solaris) NON-Solaris Package format: Apply patch 123042-01 or later.

-- x86 Platform --

N1 Grid Engine 6.0: Apply patch 123039-01 or later.

N1 Grid Engine 6.0 NON-Solaris Package format: Apply patch 123043-01 or later.

N1 Grid Engine 6.0 (x64): Apply patch 123040-01 or later.

N1 Grid Engine 6.0 (x64) NON-Solaris Package format: Apply patch 123044-01 or later.

-- Linux --

N1 Grid Engine 6.0: Apply patch 123045-01 or later.

N1 Grid Engine 6.0 (x64): Apply patch 123046-01 or later.

-- Windows --

N1 Grid Engine 6.0: Apply patch 123052-01 or later.

-- HP-UX --

N1 Grid Engine 6.0: Apply patch 123050-01 or later.

-- AIX --

N1 Grid Engine 6.0 (for AIX 4.3): Apply patch 123047-01 or later.

N1 Grid Engine 6.0 (for AIX 5.1): Apply patch 123048-01 or later.

-- Mac OS --

N1 Grid Engine 6.0: Apply patch 123049-01 or later.

-- IRIX --

N1 Grid Engine 6.0 (for IRIX 6.5): Apply patch 123051-01 or later.

NOTE: Sun Grid Engine 5.3 requires an upgrade to N1 Grid Engine 6.0 with the appropriate patches to resolve this issue.

PROVIDED AND/OR DISCOVERED BY: Reported by the vendor.

ORIGINAL ADVISORY: http://sunsolve.sun.com/search/document.do?assetkey=1-26-102322-1


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.