[SA20100] FreeType "read_lwfn()" Integer Overflow Vulnerability

2006-05-19T00:00:00
ID SECURITYVULNS:DOC:12730
Type securityvulns
Reporter Securityvulns
Modified 2006-05-19T00:00:00

Description

TITLE: FreeType "read_lwfn()" Integer Overflow Vulnerability

SECUNIA ADVISORY ID: SA20100

VERIFY ADVISORY: http://secunia.com/advisories/20100/

CRITICAL: Moderately critical

IMPACT: DoS, System access

WHERE: >From remote

SOFTWARE: FreeType 2.x http://secunia.com/product/10004/

DESCRIPTION: A vulnerability has been reported in FreeType, which can be exploited by malicious people to cause a DoS (Denial of Service) and potentially compromise applications using the library.

The vulnerability is caused due to an integer overflow error within the "read_lwfn()" function in src/base/ftmac.c. This can potentially be exploited to cause a heap-based buffer overflow via a specially crafted LWFN file.

The vulnerability has been reported in version 2.2. Prior versions may also be affected.

SOLUTION: Update to version 2.2.1. http://sourceforge.net/project/showfiles.php?group_id=3157&package_id=3121

PROVIDED AND/OR DISCOVERED BY: Reported by vendor.

ORIGINAL ADVISORY: http://sourceforge.net/project/shownotes.php?release_id=416463


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.