[SA19834] FilZip unacev2.dll Buffer Overflow Vulnerability

2006-05-15T00:00:00
ID SECURITYVULNS:DOC:12678
Type securityvulns
Reporter Securityvulns
Modified 2006-05-15T00:00:00

Description

TITLE: FilZip unacev2.dll Buffer Overflow Vulnerability

SECUNIA ADVISORY ID: SA19834

VERIFY ADVISORY: http://secunia.com/advisories/19834/

CRITICAL: Moderately critical

IMPACT: System access

WHERE: >From remote

SOFTWARE: Filzip 3.x http://secunia.com/product/8229/

DESCRIPTION: Secunia Research has discovered a vulnerability in FilZip, which can be exploited by malicious people to compromise a user's system.

The vulnerability is caused due to a boundary error in UNACEV2.DLL when extracting an ACE archive containing a file with an overly long filename. This can be exploited to cause a stack-based buffer overflow when a user extracts a specially crafted ACE archive.

The vulnerability is related to: SA16479

The vulnerability has been confirmed in version 3.04. Other versions may also be affected.

SOLUTION: Do not extract untrusted ACE archives.

PROVIDED AND/OR DISCOVERED BY: Secunia Research

ORIGINAL ADVISORY: Secunia Research: http://secunia.com/secunia_research/2006-30/


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.