[SA19580] Gallery Unspecified Script Insertion Vulnerabilities

2006-04-10T00:00:00
ID SECURITYVULNS:DOC:12142
Type securityvulns
Reporter Securityvulns
Modified 2006-04-10T00:00:00

Description

TITLE: Gallery Unspecified Script Insertion Vulnerabilities

SECUNIA ADVISORY ID: SA19580

VERIFY ADVISORY: http://secunia.com/advisories/19580/

CRITICAL: Moderately critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: Gallery 1.x http://secunia.com/product/1933/

DESCRIPTION: Some vulnerabilities have been reported in Gallery, which can be exploited by malicious people to conduct script insertion attacks.

Some unspecified input is not properly sanitised before being used. This can be exploited to inject arbitrary HTML and script code, which will be executed in a user's browser session in context of an affected site when the malicious user data is viewed.

SOLUTION: Update to version 1.5.3. http://gallery.menalto.com/downloads

PROVIDED AND/OR DISCOVERED BY: The vendor credits Aditya Mooley.


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.