[SA19446] OneOrZero "id" SQL Injection Vulnerability

2006-03-29T00:00:00
ID SECURITYVULNS:DOC:12024
Type securityvulns
Reporter Securityvulns
Modified 2006-03-29T00:00:00

Description

TITLE: OneOrZero "id" SQL Injection Vulnerability

SECUNIA ADVISORY ID: SA19446

VERIFY ADVISORY: http://secunia.com/advisories/19446/

CRITICAL: Moderately critical

IMPACT: Manipulation of data

WHERE: >From remote

SOFTWARE: OneOrZero Helpdesk 1.x http://secunia.com/product/1568/

DESCRIPTION: Preddy has discovered a vulnerability in OneOrZero, which can be exploited by malicious people to conduct SQL injection attacks.

Input passed to the "id" parameter in index.php isn't properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

Example: http://[host]/index.php?t=kbase&act=kans&id=[sql]

The vulnerability has been confirmed in version 1.6.3.0. Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly sanitised.

PROVIDED AND/OR DISCOVERED BY: Preddy


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.