[SA19281] jabberd SASL Negotiation Denial of Service Vulnerability

2006-03-20T00:00:00
ID SECURITYVULNS:DOC:11870
Type securityvulns
Reporter Securityvulns
Modified 2006-03-20T00:00:00

Description

TITLE: jabberd SASL Negotiation Denial of Service Vulnerability

SECUNIA ADVISORY ID: SA19281

VERIFY ADVISORY: http://secunia.com/advisories/19281/

CRITICAL: Moderately critical

IMPACT: DoS

WHERE: >From remote

SOFTWARE: jabberd 2.x http://secunia.com/product/2730/

DESCRIPTION: A vulnerability has been reported in jabberd, which can be exploited by malicious people to cause a DoS (Denial of Service).

The vulnerability is caused due to an error within the handling of SASL negotiation. This can be exploited to cause a crash by sending a "response" stanza before an "auth" stanza.

The vulnerability has been reported in version 2.0.

SOLUTION: Update to version 2.0s11. http://jabberstudio.org/projects/jabberd2/releases/view.php?id=826

PROVIDED AND/OR DISCOVERED BY: Reported by vendor.

ORIGINAL ADVISORY: http://article.gmane.org/gmane.network.jabber.admin/27372


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.