[SA18751] DataparkSearch Unspecified Cross-Site Scripting Vulnerability

2006-02-10T00:00:00
ID SECURITYVULNS:DOC:11363
Type securityvulns
Reporter Securityvulns
Modified 2006-02-10T00:00:00

Description

TITLE: DataparkSearch Unspecified Cross-Site Scripting Vulnerability

SECUNIA ADVISORY ID: SA18751

VERIFY ADVISORY: http://secunia.com/advisories/18751/

CRITICAL: Less critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: DataparkSearch 4.x http://secunia.com/product/7889/

DESCRIPTION: A vulnerability has been reported in DataparkSearch, which can be exploited by malicious people to conduct cross-site scripting attacks.

Some unspecified input isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

The vulnerability has been reported in version 4.36. Prior versions may also be affected.

SOLUTION: Update to version 4.37: http://www.dataparksearch.org/dpsearch-4.37.tar.gz

PROVIDED AND/OR DISCOVERED BY: Reported by the vendor.


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.