[SA18643] GIT "git-checkout-index" Symbolic Link Handling Buffer Overflow

2006-01-31T00:00:00
ID SECURITYVULNS:DOC:11244
Type securityvulns
Reporter Securityvulns
Modified 2006-01-31T00:00:00

Description

TITLE: GIT "git-checkout-index" Symbolic Link Handling Buffer Overflow

SECUNIA ADVISORY ID: SA18643

VERIFY ADVISORY: http://secunia.com/advisories/18643/

CRITICAL: Moderately critical

IMPACT: System access

WHERE: >From remote

SOFTWARE: GIT 1.x http://secunia.com/product/7172/

DESCRIPTION: A vulnerability has been reported in GIT, which potentially can be exploited by malicious people to compromise a user's system.

The vulnerability is caused due to a boundary error in "git-checkout-index" in the handling of an overly long symbolic link. This can be exploited to cause a stack-based buffer overflow and may allow execution of arbitrary code when the user performs a checkout.

Successful exploitation requires that a blob record with a specially-crafted symbolic link exists in the index, e.g. after merging with non-trusted sources.

The vulnerability has been reported in version 1.1.4. Prior versions may also be affected.

SOLUTION: Update to version 1.1.5 or later. http://www.kernel.org/pub/software/scm/git/

PROVIDED AND/OR DISCOVERED BY: The vendor credits Mark Wooding.

ORIGINAL ADVISORY: http://lwn.net/Articles/169623/


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.