16503 matches found
Agent-Security-Regression-Harness
OWASP Agent Security Regression Harness The OWASP Agent Security Regression Harness is an open source, vendor-neutral test harness for running executable security regression scenarios against agentic applications and MCP-integrated systems. The project helps builders and defenders verify that...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
CVE-2023-33107
writeup https://keto0422.github.io/2026/02/11/cve-writeup/ test video https://github.com/user-attachments/assets/1e2d1757-2fff-4cf8-a48d-bb6e2d4f5994...
malicious-pdf
Malicious PDF Generator ☠️ Generate 67 malicious PDF test files for testing phone-home callbacks, SSRF, XSS, XXE, NTLM credential theft, and data exfiltration in PDF viewers, converters, and web applications. Can be used with Burp Collaborator or Interact.sh Used for penetration testing, bug bount...
golddigger
Gold Digger Search files for gold Gold Digger is a simple tool used to help quickly discover sensitive information in files recursively. Originally written to assist in rapidly searching files obtained during a penetration test. Installation Gold Digger requires Python3. virtualenv -p python3...
test-certs-site
test-certs-site Introducción Este es un servidor web diseñado específicamente para alojar las páginas de prueba requeridas por los Requisitos Base del foro CA/Browser. Contienen el siguiente requisito: La AC DEBERÁ alojar páginas web de prueba que permitan a los Proveedores de Software de...
CVE-2024-34351
CVE-2024-34351 Test-bed for CVE-2024-34351: I used the latest vulnerable version of Next.js, which is 14.1.0. Set up the environment with the following command: npm install npm run dev...
sticky_keys_hunter
Sticky Keys Hunter This POC bash script tests for sticky keys and utilman backdoors. The script will connect to an RDP server, send both the sticky keys and utilman triggers and screenshot the result. This script was written to prove a theory I had about detecting these backdoors in a blackbox...
SpoofcheckSelfTest
SpoofCheck Self Test Web application that lets you test if your domain is vulnerable to email spoofing. NOTE: This application is still in development. Installation: This application is designed to be used as a service. However, if you want to host this yourself, do the following: git clone...
cve-2009-3555-test-server
What is this? This is a TLS server using a vendored fork of the Go TLS stack that has renegotation indication extension forcibly disabled, which will trigger CVE-2009-3555 mitigations in OpenSSL 3.0+. Note that it isn't truly vulnerable to CVE-2009-3555 because the Go TLS stack doesn't allow...
vscode-github-token-grab-extension
hello-world README DO NOT INSTALL. This is an extension for me testing out vscode publishing...
test-vuln
test-vuln a controlled environment to test CVE-2025-55182...
CVE-2022-28219-Like
CVE-2022-28219-Like Crear un entorno de prueba con un concepto similar a CVE-2022-28219...
pentest-guide
Guía de Pruebas de Penetración basada en OWASP + Extra Esta guía está dirigida a los probadores de penetración que buscan los casos de prueba adecuados requeridos durante un proyecto de prueba de penetración. Reorganicé la OWASP Testing Guide v4 desde mi punto de vista incluyendo 9 Clases de Prue...
boringssl
BoringSSL BoringSSL is a fork of OpenSSL that is designed to meet Google's needs. Although BoringSSL is an open source project, it is not intended for general use, as OpenSSL is. We don't recommend that third parties depend upon it. Doing so is likely to be frustrating because there are no...
fuzzowski
Fuzzowski █ █ ████████ ██████████ ██ ████ ██ ██ ████ ██ ████ ████ █ ████████████ █ █ ██████████ █ Fuzzowski Network Fuzzer █ █ █ █ 🄯 Fuzzers, inc. ██ ██ by Mario Rivas La idea es ser el Fuzzer de Protocolos de Red que queramos usar. El objetivo de esta herramienta es ayudar durante todo el proces...
The vulnerability of the Test IT testing management system, related to the use of default login credentials, allows attackers to compromise the confidentiality, integrity, and accessibility of protected information.
The vulnerability of the Test IT testing management system is related to the use of default login credentials. Exploiting this vulnerability allows a malicious actor to compromise the confidentiality, integrity, and accessibility of the protected information...
The vulnerability of the Test IT testing system, related to insufficient validation of requests on the server side, allows a hacker to perform an SSRF attack.
The vulnerability of the Test IT testing management system is related to insufficient testing of server-side requests. Exploiting this vulnerability allows a malicious actor to perform an SSRF attack remotely...
The vulnerability of the Test IT testing system lies in the use of external control inputs for class selection, allowing a perpetrator to execute arbitrary commands.
The vulnerability of the Test IT testing system relates to the use of externally controlled input data for class selection. Exploiting this vulnerability allows a malicious actor to execute arbitrary commands remotely...
distributed-system-testing
Distributed Systems Testing Skills Two skills for AI coding agents that design and run claim-driven tests for distributed and stateful systems. Together they produce a structured Markdown test plan and a findings report with 10-state verdicts and an explicit SUT / harness / checker / environment...