43 matches found
PT-2019-20097
Name of the Vulnerable Software and Affected Versions putty versions prior to 0.72 Description The issue affects the obsolete SSH-1 protocol and is available before host key checking. Additionally, there is a vulnerability in all the SSH client tools if a malicious program can impersonate Pageant...
Recommended update for putty (moderate)
openSUSE Security Update: Recommended update for putty Announcement ID: openSUSE-SU-2019:2017-1 Rating: moderate References: 1144547 1144548 Affected Products: openSUSE Backports SLE-15-SP1 openSUSE Backports SLE-15 An update that contains security fixes can now be installed. Description: This...
OPENSUSE-SU-2019:1985-1 Recommended update for putty
This update for putty fixes the following issues: Update to new upstream release 0.72 boo1144547, boo1144548 Fixed two separate vulnerabilities affecting the obsolete SSH-1 protocol, both available before host key checking. Fixed a vulnerability in all the SSH client tools PuTTY, Plink, PSFTP and...
PT-2019-20095
Name of the Vulnerable Software and Affected Versions putty versions prior to 0.72 Description The issue affects the obsolete SSH-1 protocol and is available before host key checking. Additionally, there is a vulnerability in all the SSH client tools, including PuTTY, Plink, PSFTP, and PSCP, if a...
Recommended update for putty (moderate)
openSUSE Security Update: Recommended update for putty Announcement ID: openSUSE-SU-2019:1985-1 Rating: moderate References: 1144547 1144548 Affected Products: openSUSE Leap 15.1 openSUSE Leap 15.0 An update that contains security fixes can now be installed. Description: This update for putty fix...
FreeBSD : PuTTY 0.72 -- buffer overflow in SSH-1 and integer overflow in SSH client (5914705c-ab03-11e9-a4f9-080027ac955c)
Simon Tatham reports : Vulnerabilities fixed in this release include : - A malicious SSH-1 server could trigger a buffer overrun by sending extremely short RSA keys, or certain bad packet length fields. Either of these could happen before host key verification, so even if you trust the server you...
PuTTY 0.72 -- buffer overflow in SSH-1 and integer overflow in SSH client
Simon Tatham reports: Vulnerabilities fixed in this release include: A malicious SSH-1 server could trigger a buffer overrun by sending extremely short RSA keys, or certain bad packet length fields. Either of these could happen before host key verification, so even if you trust the server you...
CVE-2001-1473
The SSH-1 protocol allows remote servers to conduct man-in-the-middle attacks and replay a client challenge response to a target server by creating a Session ID that matches the Session ID of the target, but which uses a public key pair that is weaker than the target's public key, which allows th...
Deprecated SSH-1 Protocol Detection
The host is running SSH and is providing / accepting one or more deprecated versions of the SSH protocol which have known cryptographic flaws. SPDX-FileCopyrightText: 2011 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right...
SOL6736 - OpenSSH vulnerabilities CAN-2006-5051, CAN-2006-4924
This security advisory describes an OpenSSH Signal Handling vulnerability CVE-2006-5051. A remote attacker could possibly leverage this flaw to cause a denial of service. This security advisory also describes a denial of service bug CVE-2006-4924 in the OpenSSH sshd server. A remote attacker can...
CVE-2001-1466
CVE-2001-1466 : The connected sources confirm a vulnerability in VanDyke SecureCRT (pre-3.4.2) where a buffer overflow is triggered by a long username or password when using the SSH-1 protocol , allowing remote code execution. The description is consistent across NVD/CVE records; exploitation det...
CVE-2001-1473
CVE-2001-1473 : The SSH-1 protocol vulnerability allows a remote attacker to perform man-in-the-middle and replay attacks by crafting a Session ID that matches the target’s Session ID but uses a weaker public key, enabling the attacker to compute the corresponding private key and masquerade as th...
CVE-2001-1473
The SSH-1 protocol allows remote servers to conduct man-in-the-middle attacks and replay a client challenge response to a target server by creating a Session ID that matches the Session ID of the target, but which uses a public key pair that is weaker than the target's public key, which allows th...
CVE-2001-1473: Undefined Security Weakness
The SSH-1 protocol allows remote servers to conduct man-in-the-middle attacks and replay a client challenge response to a target server by creating a Session ID that matches the Session ID of the target, but which uses a public key pair that is weaker than the target's public key, which allows th...
CVE-2001-1466: Undefined Security Weakness
Buffer overflow in VanDyke SecureCRT before 3.4.2, when using the SSH-1 protocol, allows remote attackers to execute arbitrary code via a long 1 username or 2 password...
CVE-2001-1466
Buffer overflow in VanDyke SecureCRT before 3.4.2, when using the SSH-1 protocol, allows remote attackers to execute arbitrary code via a long 1 username or 2 password...
CVE-2001-0361
CVE-2001-0361 affects SSH v1.5 implementations, notably OpenSSH up to 2.3.0, AppGate, and ssh-1 up to 1.2.31, when configured in certain ways. The issue enables a remote attacker to decrypt and/or alter traffic via a Bleichenbacher attack on PKCS#1 version 1.5. The connected PT security entries (...
CVE-2001-0361: Undefined Security Weakness
Implementations of SSH version 1.5, including 1 OpenSSH up to version 2.3.0, 2 AppGate, and 3 ssh-1 up to version 1.2.31, in certain configurations, allow a remote attacker to decrypt and/or alter traffic via a "Bleichenbacher attack" on PKCS1 version 1.5...
CVE-2001-0572: Undefined Security Weakness
The SSH protocols 1 and 2 aka SSH-2 as implemented in OpenSSH and other packages have various weaknesses which can allow a remote attacker to obtain the following information via sniffing: 1 password lengths or ranges of lengths, which simplifies brute force password guessing, 2 whether RSA or DS...
CVE-2001-0471
CVE-2001-0471 applies to SSH1 (SSH server 1.2.30 or earlier). The issue is that SSH1 SSH Daemon does not log repeated login attempts, which could allow remote attackers to carry out brute-force-style account compromises without detection. Multiple connected sources (NVD/Nessus/OpenVAS entries) co...