103 matches found
10cartsharing (>=1.0.0, <=1.0.3), 1api (>=0.0.1, <=0.0.2) +7935 more potentially affected by CVE-2022-2421 via socket.io-parser (>=2.2.2, <=3.3.0)
socket.io-parser NPM version =2.2.2, =1.0.0, =0.0.1, =0.0.1, =0.1.0, =1.0.2, =1.0.1, =2.16.1, =1.0.0-RC.1, =0.1.0, =1.0.0, =1.3.2 - 88slot-ap 1.0.0 and more Source cves: CVE-2022-2421 Source advisory: MEND:CVE-2022-2421...
@ckeditor/ckeditor-cloud-services-collaboration (>=23.0.0, <=29.0.0), @ckeditor/ckeditor5-real-time-collaboration (>=29.1.0, <=33.0.0) +2 more potentially affected by CVE-2022-2421 via socket.io-parser (3.4.1)
socket.io-parser NPM version 3.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on socket.io-parser and may be impacted: - @ckeditor/ckeditor-cloud-services-collaboration =23.0.0, =29.1.0, =29.0.0, =1.5.3, =2.1.0 Source cves: CVE-2022-2421 Source...
@asigna/stx-core-sdk (0.0.1), @casper124578/use-socket.io (>=2.1.0, <=4.1.0) +133 more potentially affected by CVE-2022-2421 via socket.io-parser (4.1.2)
socket.io-parser NPM version 4.1.2 is affected by a known vulnerability. The following packages have a transitive dependency on socket.io-parser and may be impacted: - @asigna/stx-core-sdk 0.0.1 - @casper124578/use-socket.io =2.1.0, =31.0.0, =34.0.0, =34.0.0, =1.0.0-theia1.27.0, =1.0.0, =1.0.1,...
socket.io (>=3.0.0-rc1, <=3.0.0-rc4), socket.io-client (>=3.0.0-rc1, <=3.0.0-rc4) potentially affected by CVE-2022-2421 via socket.io-parser (>=4.0.1-rc1, <=4.0.1-rc3)
socket.io-parser NPM version =4.0.1-rc1, =3.0.0-rc1, =3.0.0-rc1, =3.0.0-rc4 Source cves: CVE-2022-2421 Source advisory: MEND:CVE-2022-2421...
Resource exhaustion in socket.io-parser
Overview The socket.io-parser npm package before versions 3.3.2 and 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used. Recommendation Upgrade to versions 3.3.2, 3.4.1 or later References - CVE - GitHub Advisory...
Resource exhaustion in socket.io-parser
The socket.io-parser npm package before versions 3.3.2 and 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used...
GHSA-XFHH-G9F5-X4M4 Resource exhaustion in socket.io-parser
The socket.io-parser npm package before versions 3.3.2 and 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used...
@abcpros/bitcore-build (>=8.25.29, <=8.25.30), @acanto/october-scripts (3.2.2) +1118 more potentially affected by CVE-2020-36049 via socket.io-parser (>=3.1.1, <=3.3.0)
socket.io-parser NPM version =3.1.1, =8.25.29, =1.0.0, =2018.7.11-0, =0.1.14, =1.0.2, =1.0.0, =1.2.0, =0.2.0-preview.3, =0.2.0, =1.0.10, =3.3.91, =3.3.114 and more Source cves: CVE-2020-36049 Source advisory: OSV:GHSA-XFHH-G9F5-X4M4...
@abcpros/bitcore-build (>=8.25.29, <=8.25.30), @acanto/october-scripts (3.2.2) +1118 more potentially affected by CVE-2020-36049 via socket.io-parser (>=3.1.1, <=3.3.0)
socket.io-parser NPM version =3.1.1, =8.25.29, =1.0.0, =2018.7.11-0, =0.1.14, =1.0.2, =1.0.0, =1.2.0, =0.2.0-preview.3, =0.2.0, =1.0.10, =3.3.91, =3.3.114 and more Source cves: CVE-2020-36049 Source advisory: GHSA-XFHH-G9F5-X4M4...
CVE-2020-36049
An uncontrolled resource consumption vulnerability was found in socket.io-parser. If an attacker crafts a packet with a very large payload length, this can cause the parser to consume an ever-increasing amount of memory, resulting in a denial of service. The highest threat from this vulnerability...
Denial Of Service (DoS)
socket.io-parser is vulnerable to denial of service. The vulnerability exists due to the building up of ConsOneByteString objects caused by a concatenation approach when maxHttpBufferSize is set to a large size...
DEBIAN-CVE-2020-36049
socket.io-parser before 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used...
CVE-2020-36049
socket.io-parser before 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used...
Design/Logic Flaw
socket.io-parser before 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used...
CVE-2020-36049
socket.io-parser before 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used...
CVE-2020-36049
socket.io-parser before 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used...
CVE-2020-36049
socket.io-parser before 3.4.1 allows attackers to cause a denial of service memory consumption via a large packet because a concatenation approach is used...
CVE-2020-36049
CVE-2020-36049 affects socket.io-parser; before version 3.4.1 it allows memory exhaustion/DoS via a large packet due to the library’s concatenation approach. Affected component is socket.io-parser (used with socket.io). The issue results in elevated memory usage and potential denial of service un...
10cartsharing (>=1.0.0, <=1.0.3), 1api (>=0.0.1, <=0.0.2) +7935 more potentially affected by CVE-2020-36049 via socket.io-parser (>=2.2.2, <=3.3.0)
socket.io-parser NPM version =2.2.2, =1.0.0, =0.0.1, =0.0.1, =0.1.0, =1.0.2, =1.0.1, =2.16.1, =1.0.0-RC.1, =0.1.0, =1.0.0, =1.3.2 - 88slot-ap 1.0.0 and more Source cves: CVE-2020-36049 Source advisory: MEND:CVE-2020-36049...