103 matches found
CLSA-2026-1776731787 TuxCare security update for socket.io-parser (3 CVEs)
TuxCare rebuilt socket.io-parser to address 3 CVEs. Fixed in 3.1.3-tuxcare.1...
CLSA-2026-1772496675 TuxCare security update for socket.io-parser (3 CVEs)
TuxCare rebuilt socket.io-parser to address 3 CVEs. Fixed in 3.2.0-tuxcare.1...
PT-2026-75614
TuxCare rebuilt socket.io-parser to address 1 CVE. Fixed in 3.2.0-tuxcare.2...
PT-2026-74835
TuxCare rebuilt socket.io-parser to address 2 CVEs. Fixed in 3.4.3-tuxcare.1...
PT-2026-74510
TuxCare rebuilt socket.io-parser to address 4 CVEs. Fixed in 3.1.3-tuxcare.1...
PT-2026-74836
TuxCare rebuilt socket.io-parser to address 1 CVE. Fixed in 4.2.4-tuxcare.1...
PT-2026-73826
TuxCare rebuilt socket.io-parser to address 3 CVEs. Fixed in 3.2.0-tuxcare.1...
PT-2026-74837
TuxCare rebuilt socket.io-parser to address 1 CVE. Fixed in 3.3.4-tuxcare.1...
Improper Check for Unusual or Exceptional Conditions
Overview socket.io-parser is a socket.io protocol parser Affected versions of this package are vulnerable to Improper Check for Unusual or Exceptional Conditions via attachment handling. An attacker can cause the server to exhaust memory resources by sending specially crafted packets that make th...
@ckeditor/ckeditor-cloud-services-collaboration (>=23.0.0, <=29.0.0), @ckeditor/ckeditor5-real-time-collaboration (>=29.1.0, <=33.0.0) +2 more potentially affected by CVE-2026-69185 via socket.io-parser (3.4.1)
socket.io-parser NPM version 3.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on socket.io-parser and may be impacted: - @ckeditor/ckeditor-cloud-services-collaboration =23.0.0, =29.1.0, =29.0.0, =1.5.3, =2.1.0 Source cves: CVE-2026-69185 Source...
0.edsql (>=1.0.49, <=1.0.50), 10secondsofcode-custom (1.0.0) +2634 more potentially affected by CVE-2026-69185 via socket.io-parser (>=4.0.1-rc1, <=4.2.6)
socket.io-parser NPM version =4.0.1-rc1, =1.0.49, =1.0.0, =0.0.28, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =1.0.1, =0.8.2, =1.0.0, =0.1.13, =0.0.4, =0.0.9 and more Source cves: CVE-2026-69185 Source advisory: GHSA-2M8V-J782-FHVR...
@ckeditor/ckeditor-cloud-services-collaboration (>=23.0.0, <=29.0.0), @ckeditor/ckeditor5-real-time-collaboration (>=29.1.0, <=33.0.0) +2 more potentially affected by CVE-2026-69185 via socket.io-parser (3.4.1)
socket.io-parser NPM version 3.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on socket.io-parser and may be impacted: - @ckeditor/ckeditor-cloud-services-collaboration =23.0.0, =29.1.0, =29.0.0, =1.5.3, =2.1.0 Source cves: CVE-2026-69185 Source...
0.edsql (>=1.0.49, <=1.0.50), 10secondsofcode-custom (1.0.0) +2634 more potentially affected by CVE-2026-69185 via socket.io-parser (>=4.0.1-rc1, <=4.2.6)
socket.io-parser NPM version =4.0.1-rc1, =1.0.49, =1.0.0, =0.0.28, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =1.0.1, =0.8.2, =1.0.0, =0.1.13, =0.0.4, =0.0.9 and more Source cves: CVE-2026-69185 Source advisory: OSV:GHSA-2M8V-J782-FHVR...
NPM: Socket.IO: Zero-attachment Memory Exhaustion
NPM: Socket.IO: Zero-attachment Memory Exhaustion vulnerability discovered by ? in WordPress Npm socket.io-parser versions 3.3.6...
@abcpros/bitcore-build (>=8.25.29, <=8.25.30), @acanto/october-scripts (3.2.2) +1123 more potentially affected by CVE-2026-69185 via socket.io-parser (>=3.1.1, <=3.3.5)
socket.io-parser NPM version =3.1.1, =8.25.29, =1.0.0, =2018.7.11-0, =0.1.14, =1.0.2, =1.0.0, =1.2.0, =0.2.0-preview.3, =0.2.0, =1.0.10, =3.3.91, =3.3.114 and more Source cves: CVE-2026-69185 Source advisory: OSV:GHSA-2M8V-J782-FHVR...
Improper Check for Unusual or Exceptional Conditions
Overview org.webjars.npm:socket.io-parser is a socket.io protocol parser Affected versions of this package are vulnerable to Improper Check for Unusual or Exceptional Conditions via attachment handling. An attacker can cause the server to exhaust memory resources by sending specially crafted...
@abcpros/bitcore-build (>=8.25.29, <=8.25.30), @acanto/october-scripts (3.2.2) +1123 more potentially affected by CVE-2026-69185 via socket.io-parser (>=3.1.1, <=3.3.5)
socket.io-parser NPM version =3.1.1, =8.25.29, =1.0.0, =2018.7.11-0, =0.1.14, =1.0.2, =1.0.0, =1.2.0, =0.2.0-preview.3, =0.2.0, =1.0.10, =3.3.91, =3.3.114 and more Source cves: CVE-2026-69185 Source advisory: GHSA-2M8V-J782-FHVR...
@ckeditor/ckeditor-cloud-services-collaboration (>=23.0.0, <=29.0.0), @ckeditor/ckeditor5-real-time-collaboration (>=29.1.0, <=33.0.0) +2 more potentially affected by CVE-2026-69185 via socket.io-parser (3.4.1)
socket.io-parser NPM version 3.4.1 is affected by a known vulnerability. The following packages have a transitive dependency on socket.io-parser and may be impacted: - @ckeditor/ckeditor-cloud-services-collaboration =23.0.0, =29.1.0, =29.0.0, =1.5.3, =2.1.0 Source cves: CVE-2026-69185 Source...
@abcpros/bitcore-build (>=8.25.29, <=8.25.30), @acanto/october-scripts (3.2.2) +1123 more potentially affected by CVE-2026-69185 via socket.io-parser (>=3.1.1, <=3.3.5)
socket.io-parser NPM version =3.1.1, =8.25.29, =1.0.0, =2018.7.11-0, =0.1.14, =1.0.2, =1.0.0, =1.2.0, =0.2.0-preview.3, =0.2.0, =1.0.10, =3.3.91, =3.3.114 and more Source cves: CVE-2026-69185 Source advisory: SNYK:JS-SOCKETIOPARSER-18517008...
0.edsql (>=1.0.49, <=1.0.50), 10secondsofcode-custom (1.0.0) +2634 more potentially affected by CVE-2026-69185 via socket.io-parser (>=4.0.1-rc1, <=4.2.6)
socket.io-parser NPM version =4.0.1-rc1, =1.0.49, =1.0.0, =0.0.28, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =1.0.1, =0.8.2, =1.0.0, =0.1.13, =0.0.4, =0.0.9 and more Source cves: CVE-2026-69185 Source advisory: SNYK:JS-SOCKETIOPARSER-18517008...