Lucene search
+L

17 matches found

EUVD
EUVD
•added 2025/10/07 12:30 a.m.•16 views

EUVD-2019-0540

Malware in sbrugna...

5.3CVSS5.8AI score0.01477EPSS
SaveExploits0References6
BDU FSTEC
BDU FSTEC
•added 2024/06/04 12:00 a.m.•21 views

Mojolicious secure_compare Length Disclosure

The vulnerability of the securecompare function in the Mojolicious module relates to manipulating an unknown input, which leads to a timing mismatch vulnerability. Exploiting this vulnerability could allow a remote attacker to obtain the length of the secret string...

7.8CVSS7.4AI score0.00511EPSS
SaveExploits0References5Affected Software3
Redos
Redos
•added 2024/06/03 12:00 a.m.•30 views

ROS-20240603-02

A vulnerability in the Format Detection component of the Mojolicious module for Perl is related to errors in releasing resources. Exploitation of the vulnerability could allow an attacker acting remotely to cause a denial of denial of service A vulnerability in the securecompare function of the...

7.5CVSS6.2AI score0.00554EPSS
SaveExploits1
osv_azl
osv_azl
•added 2024/04/08 12:15 a.m.•21 views

AZL-45018 CVE-2020-36829 affecting package perl-Mojolicious 8.57-3

The Mojolicious module before 8.65 for Perl is vulnerable to securecompare timing attacks that allow an attacker to guess the length of a secret string. Only versions after 1.74 are affected...

7.5CVSS7.1AI score0.00511EPSS
SaveExploits0References1
osv_ubuntu
osv_ubuntu
•added 2024/04/08 12:15 a.m.•27 views

UBUNTU-CVE-2020-36829

The Mojolicious module before 8.65 for Perl is vulnerable to securecompare timing attacks that allow an attacker to guess the length of a secret string. Only versions after 1.74 are affected...

7.5CVSS7.1AI score0.00511EPSS
SaveExploits0References4
Positive Technologies
Positive Technologies
•added 2024/04/07 12:00 a.m.•17 views

PT-2024-3925 · Unknown +2 · Mojolicious +2

Name of the Vulnerable Software and Affected Versions: Mojolicious module versions 1.74 through 8.64 Description: The issue is related to a timing attack vulnerability in the secure compare function of the Mojolicious module for Perl. This vulnerability allows an attacker to manipulate unknown...

7.8CVSS6.2AI score0.00554EPSS
SaveExploits1References25
Github Security Blog
Github Security Blog
•added 2019/06/03 5:28 p.m.•33 views

Insecure Comparison in secure-compare

Versions of secure-compare prior to 3.0.1 are affected by a vulnerability that results in the package always returning true when comparing two strings of the same length, despite differences in the contents of those strings. Recommendation Upgrade to version 3.0.1 or later...

5.3CVSS5.4AI score0.01477EPSS
SaveExploits0References5Affected Software1
osv_ghsa
osv_ghsa
•added 2019/06/03 5:28 p.m.•21 views

GHSA-H9X2-5RM7-X4GM Insecure Comparison in secure-compare

Versions of secure-compare prior to 3.0.1 are affected by a vulnerability that results in the package always returning true when comparing two strings of the same length, despite differences in the contents of those strings. Recommendation Upgrade to version 3.0.1 or later...

5.3CVSS5.1AI score0.01477EPSS
SaveExploits0References4
Prion
Prion
•added 2018/05/31 8:29 p.m.•22 views

Design/Logic Flaw

secure-compare 3.0.0 and below do not actually compare two strings properly. compare was actually comparing the first argument with itself, meaning the check passed for any two strings of the same length...

5CVSS7.1AI score0.01477EPSS
SaveExploits0References2Affected Software1
NVD
NVD
•added 2018/05/31 8:29 p.m.•23 views

CVE-2015-9238

secure-compare 3.0.0 and below do not actually compare two strings properly. compare was actually comparing the first argument with itself, meaning the check passed for any two strings of the same length...

5.3CVSS5.4AI score0.01477EPSS
SaveExploits0References2
Cvelist
Cvelist
•added 2018/05/31 8:00 p.m.•33 views

CVE-2015-9238

secure-compare 3.0.0 and below do not actually compare two strings properly. compare was actually comparing the first argument with itself, meaning the check passed for any two strings of the same length...

5.3AI score0.01477EPSS
SaveExploits0References2
Mend
Mend
•added 2018/05/31 8:00 p.m.•9 views

CVE-2015-9238

secure-compare 3.0.0 and below do not actually compare two strings properly. compare was actually comparing the first argument with itself, meaning the check passed for any two strings of the same length...

6.9CVSS0.01477EPSS
SaveExploits0References5
CVE
CVE
•added 2018/05/31 8:00 p.m.•69 views

CVE-2015-9238

The CVE-2015-9238 issue affects the secure-compare package (Node ecosystem). Versions prior to 3.0.1 incorrectly compare two strings: the check compares the first argument with itself, allowing any two strings of the same length to pass. Affected component: secure-compare (npm/Node.js environment...

5.3CVSS5.3AI score0.01477EPSS
SaveExploits0References2Affected Software1
Positive Technologies
Positive Technologies
•added 2018/05/31 12:00 a.m.•9 views

PT-2018-4551

Name of the Vulnerable Software and Affected Versions secure-compare versions prior to 3.0.1 Description The issue arises from the secure-compare function comparing the first argument with itself instead of comparing two different strings. This results in the function always returning true when...

5.3CVSS0.01477EPSS
SaveExploits0References6
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2018/05/31 12:00 a.m.•8 views

CVE-2015-9238: Incorrect Comparison

secure-compare 3.0.0 and below do not actually compare two strings properly. compare was actually comparing the first argument with itself, meaning the check passed for any two strings of the same length...

5.3CVSS5.9AI score0.01477EPSS
SaveExploits0References3
attackerkb
attackerkb
•added 2017/09/01 1:29 p.m.•115 views

CVE-2017-12868

The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows attackers to conduct session fixation attacks or possibly bypass authentication by leveraging missing character conversions before an XOR operation...

9.8CVSS5.7AI score0.02133EPSS
SaveExploits0References5
nodejs
nodejs
•added 2015/10/24 6:09 p.m.•41 views

Insecure Comparison

Overview Versions of secure-compare prior to 3.0.1 are affected by a vulnerability that results in the package always returning true when comparing two strings of the same length, despite differences in the contents of those strings. Recommendation Upgrade to version 3.0.1 or later. References - ...

5CVSS4.8AI score0.01477EPSS
SaveExploits0Affected Software1
Rows per page
Query Builder