Insecure Comparison

2015-10-24T21:00:53
ID NODEJS:50
Type nodejs
Reporter Joshua Dague
Modified 2018-05-08T14:27:01

Description

Overview

Versions of secure-compare prior to 3.0.1 are affected by a vulnerability that results in the package always returning true when comparing two strings of the same length, despite differences in the contents of those strings.

Recommendation

Upgrade to version 3.0.1 or later.

References

PR #1