Lucene search
+L

19512 matches found

RubySec
RubySec
•added 2024/07/08 12:00 a.m.•44 views

RailsAdmin Cross-site Scripting vulnerability in the list view

Impact RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. The issue was originally reported in https://github.com/railsadminteam/railsadmin/issues/3686. Patches Upgrade to 3.1.3 or 2.3.0. Workarounds 1. Copy the index view located under the path...

6.8CVSS6.7AI score0.00579EPSS
SaveExploits0References1Affected Software1
NVD
NVD
•added 2024/07/06 10:15 a.m.•37 views

CVE-2024-37260

Server-Side Request Forgery SSRF vulnerability in Theme-Ruby Foxiz.This issue affects Foxiz: from n/a through 2.3.5...

9.3CVSS0.00286EPSS
SaveExploits0References1
osv_cve
osv_cve
•added 2024/07/06 10:15 a.m.•28 views

CVE-2024-37260

Server-Side Request Forgery SSRF vulnerability in Theme-Ruby Foxiz.This issue affects Foxiz: from n/a through 2.3.5...

9.3CVSS5.8AI score0.00286EPSS
SaveExploits0References1
CVE
CVE
•added 2024/07/06 9:46 a.m.•108 views

CVE-2024-37260

CVE-2024-37260 is a Server-Side Request Forgery (SSRF) vulnerability affecting WordPress Foxiz Theme (Foxiz) versions up to 2.3.5. Public sources (NVD, CVE listings) confirm the issue and its high/critical impact metrics (CVSS v3.1: 9.3 base score; network attack, no user interaction). The Wordfe...

9.3CVSS5.8AI score0.00286EPSS
SaveExploits0References1Affected Software1
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2024/07/06 12:00 a.m.•8 views

CVE-2024-37260: Server-Side Request Forgery (SSRF)

Server-Side Request Forgery SSRF vulnerability in Theme-Ruby Foxiz.This issue affects Foxiz: from n/a through 2.3.5...

9.3CVSS5.8AI score0.00286EPSS
SaveExploits0References1
Positive Technologies
Positive Technologies
•added 2024/07/06 12:00 a.m.•36 views

PT-2024-27425 · Foxiz · Foxiz

Name of the Vulnerable Software and Affected Versions: Foxiz versions 2.3.5 and earlier Description: A Server-Side Request Forgery SSRF vulnerability has been identified in Theme-Ruby Foxiz. This issue allows for unauthorized access to internal resources, potentially leading to sensitive data...

9.3CVSS5.6AI score0.00286EPSS
SaveExploits0References12
Tenable Nessus
Tenable Nessus
•added 2024/07/03 12:00 a.m.•28 views

CBL Mariner 2.0 Security Update: ruby / rubygem-rexml (CVE-2024-35176)

The version of ruby / rubygem-rexml installed on the remote CBL Mariner 2.0 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the CVE-2024-35176 advisory. - REXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service...

5.3CVSS6.5AI score0.02064EPSS
SaveExploits1References2
CVE
CVE
•added 2024/07/02 3:57 p.m.•110 views

CVE-2024-39316

Rack is a modular Ruby web server interface. A ReDoS vulnerability exists in Rack::Request::Helpers when parsing HTTP Accept headers, affecting Rack 3.1.0 up to, but not including, 3.1.5. An attacker can trigger excessive server processing by sending specially crafted Accept-Encoding or Accept-La...

6.5CVSS5.8AI score0.00856EPSS
SaveExploits0References3Affected Software1
Debian CVE
Debian CVE
•added 2024/07/02 3:57 p.m.•101 views

CVE-2024-39316

Rack is a modular Ruby web server interface. Starting in version 3.1.0 and prior to version 3.1.5, Regular Expression Denial of Service ReDoS vulnerability exists in the Rack::Request::Helpers module when parsing HTTP Accept headers. This vulnerability can be exploited by an attacker sending...

6.5CVSS5.8AI score0.00856EPSS
SaveExploits0
osv_cve
osv_cve
•added 2024/07/02 3:57 p.m.•42 views

CVE-2024-39316 Rack ReDoS Vulnerability in HTTP Accept Headers Parsing

Rack is a modular Ruby web server interface. Starting in version 3.1.0 and prior to version 3.1.5, Regular Expression Denial of Service ReDoS vulnerability exists in the Rack::Request::Helpers module when parsing HTTP Accept headers. This vulnerability can be exploited by an attacker sending...

6.5CVSS5.8AI score0.00856EPSS
SaveExploits0References5
Vulnrichment
Vulnrichment
•added 2024/07/02 3:57 p.m.•35 views

CVE-2024-39316 Rack ReDoS Vulnerability in HTTP Accept Headers Parsing

Rack is a modular Ruby web server interface. Starting in version 3.1.0 and prior to version 3.1.5, Regular Expression Denial of Service ReDoS vulnerability exists in the Rack::Request::Helpers module when parsing HTTP Accept headers. This vulnerability can be exploited by an attacker sending...

6.5CVSS5.8AI score0.00856EPSS
SaveExploits0References3
CNNVD
CNNVD
•added 2024/07/02 12:00 a.m.•26 views

Rack Security Vulnerabilities

Rack is a modular Ruby web server interface. A security vulnerability exists in Rack versions 3.1.0 through prior to 3.1.5, which stems from a Regular Expression Denial of Service ReDoS vulnerability that can be exploited by an attacker to send specially crafted headers that cause the server to...

6.5CVSS5.8AI score0.00856EPSS
SaveExploits0References2
osv_oesa
osv_oesa
•added 2024/06/28 11:07 a.m.•17 views

OESA-2024-1780 ruby security update

Ruby is a fast and easy interpreted scripting language for object-oriented programming. It has many functions for processing text Files and perform system management tasks such as Perl. Security Fixes: Rubygems.org is the Ruby community's gem hosting service. A Gem publisher can cause a Remote Do...

4.3CVSS5.8AI score0.00494EPSS
SaveExploits0References2
osv_oesa
osv_oesa
•added 2024/06/28 11:07 a.m.•19 views

OESA-2024-1779 rubygem-actionpack security update

Eases web-request routing, handling, and response as a half-way front, half-way page controller. Implemented with specific emphasis on enabling easy unit/integration testing that doesn't require a browser. Security Fixes: Action Pack is a framework for handling and responding to web requests. Und...

5.9CVSS6.2AI score0.02217EPSS
SaveExploits0References2
osv_usn
osv_usn
•added 2024/06/26 12:27 p.m.•26 views

USN-6853-1 ruby2.7, ruby3.0, ruby3.1 vulnerability

It was discovered that Ruby incorrectly handled the ungetbyte and ungetc methods. A remote attacker could use this issue to cause Ruby to crash, resulting in a denial of service, or possibly obtain sensitive information...

9.8CVSS6.7AI score0.02364EPSS
SaveExploits0References2
Ubuntu
Ubuntu
•added 2024/06/26 12:27 p.m.•47 views

USN-6853-1: Ruby vulnerability

It was discovered that Ruby incorrectly handled the ungetbyte and ungetc methods. A remote attacker could use this issue to cause Ruby to crash, resulting in a denial of service, or possibly obtain sensitive information...

9.8CVSS6.7AI score0.02364EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2024/06/26 12:00 a.m.•41 views

Ubuntu 20.04 LTS / 22.04 LTS / 23.10 : Ruby vulnerability (USN-6853-1)

The remote Ubuntu 20.04 LTS / 22.04 LTS / 23.10 host has packages installed that are affected by a vulnerability as referenced in the USN-6853-1 advisory. It was discovered that Ruby incorrectly handled the ungetbyte and ungetc methods. A remote attacker could use this issue to cause Ruby to cras...

9.8CVSS6.7AI score0.02364EPSS
SaveExploits0References2
OSSF Malicious Packages
OSSF Malicious Packages
•added 2024/06/25 1:52 p.m.•13 views

Malicious code in workarea-gift-cards (RubyGems)

--- -= Per source details. Do not edit below this line.=-...

5.3AI score
SaveExploits0References2
OSSF Malicious Packages
OSSF Malicious Packages
•added 2024/06/25 1:52 p.m.•13 views

Malicious code in vagrant_hvinfo (RubyGems)

--- -= Per source details. Do not edit below this line.=-...

5.3AI score
SaveExploits0References2
OSSF Malicious Packages
OSSF Malicious Packages
•added 2024/06/25 1:52 p.m.•12 views

Malicious code in twitter_vine (RubyGems)

--- -= Per source details. Do not edit below this line.=-...

5.3AI score
SaveExploits0References2
Rows per page
Query Builder