295344 matches found
PraisonAI: Plugin Auto-Discovery Executes Arbitrary Python Files Without Verification
SummaryThe plugin manager loads and executes arbitrary .py files from .praisonai/plugins/ directories both project-level and user home via importlib.util.specfromfilelocation + execmodule with zero code signing, integrity verification, or sandboxing. Any attacker who can write a file to the plugi...
PYSEC-2026-4271 PraisonAI: Plugin Auto-Discovery Executes Arbitrary Python Files Without Verification
Summary The plugin manager loads and executes arbitrary .py files from .praisonai/plugins/ directories both project-level and user home via importlib.util.specfromfilelocation + execmodule with zero code signing, integrity verification, or sandboxing. Any attacker who can write a file to the...
Docling imports plugin entry points before the allow_external_plugins check
Summaryallowexternalplugins=False the default, and the CLI default is meant to restrict docling to its own model plugins. However, docling's plugin factories call pluggy's loadsetuptoolsentrypoints, which imports every module registered under docling's plugin entry-point group. Only afterwards do...
omnata-cli (>=0.1.8, <=0.1.12), omnata-plugin-devkit (>=0.1.2, <=0.1.95) +3 more potentially affected by CVE-2026-86597 via snowflake-connector-python (3.2.0)
snowflake-connector-python PYPI version 3.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - omnata-cli =0.1.8, =0.1.2, =0.0.16, =0.0.1a2, =1.1.1, =1.2.5 Source cves: CVE-2026-86597 Source advisory:...
inthub-cli (>=0.1.4, <=0.1.26), omnata-plugin-devkit (>=0.5.3, <=0.11.0) +2 more potentially affected by CVE-2026-86597 via snowflake-connector-python (3.12.0)
snowflake-connector-python PYPI version 3.12.0 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - inthub-cli =0.1.4, =0.5.3, =0.5.0a112, =0.11.9 - snowflake-cli-labs 3.0.0rc0 Source cves: CVE-2026-86597...
enterprise-integrated-channels (0.1.30), omnata-cli (>=0.1.3, <=0.2.0) +3 more potentially affected by CVE-2026-86597 via snowflake-connector-python (3.7.0)
snowflake-connector-python PYPI version 3.7.0 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - enterprise-integrated-channels 0.1.30 - omnata-cli =0.1.3, =0.3.30, =2.0.0rc1, =2.1.2 Source cves:...
Important: Red Hat Security Advisory: Red Hat Connectivity Link component - rhcl-operator security update
New rhcl-1/wasm-shim-rhel9, rhcl-1/rhcl-console-plugin, rhcl-1/rhcl-operator and rhcl-1/rhcl-operator-bundle container images are now available in the Red Hat container registry. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scorin...
CVE-2026-96537
The Tutor LMS WordPress plugin before 4.1.1 does not perform a capability check in a routine that regenerates its managed pages, allowing unauthenticated users to force-publish unpublished pages and overwrite their content, create missing ones, and change the options that reference them...
CVE-2026-74920
The Document Gallery WordPress plugin through 5.1.1 does not properly sanitise and escape user input before reflecting it inside an HTML attribute in the response of an unauthenticated AJAX action, leading to a Reflected Cross-Site Scripting vulnerability which can be exploited against any visito...
EUVD-2026-101853
The Document Gallery WordPress plugin through 5.1.1 does not properly sanitise and escape user input before reflecting it inside an HTML attribute in the response of an unauthenticated AJAX action, leading to a Reflected Cross-Site Scripting vulnerability which can be exploited against any visito...
CVE-2026-96537
The Tutor LMS WordPress plugin, in versions prior to 4.1.1 , contains a vulnerability where it fails to perform a capability check during the routine that regenerates managed pages. This flaw allows unauthenticated users to force-publish unpublished pages, overwrite existing content, create new p...
CVE-2026-96537 Tutor LMS < 4.1.1 - Unauthenticated Tutor Page Force-Publish and Content Overwrite
The Tutor LMS WordPress plugin before 4.1.1 does not perform a capability check in a routine that regenerates its managed pages, allowing unauthenticated users to force-publish unpublished pages and overwrite their content, create missing ones, and change the options that reference them...
CVE-2026-103304 eaSYNC < 1.3.31 - Unauthenticated Cancellation Request Creation and Email Template Update
The eaSYNC Booking WordPress plugin before 1.3.31 does not perform authorization or nonce checks on several of its cancellation-related AJAX actions, allowing unauthenticated users to create booking cancellation requests, trigger booking notification emails, and overwrite the content of the email...
EUVD-2026-101851
The Spin Wheel WordPress plugin before 2.2.1 does not verify that a visitor actually performed a legitimate spin before returning and consuming a configured prize coupon, allowing unauthenticated users to disclose and drain the stored coupon codes of any campaign, including unpublished ones...
EUVD-2026-101849
The eaSYNC Booking WordPress plugin before 1.3.31 does not perform authorization or nonce checks on several of its cancellation-related AJAX actions, allowing unauthenticated users to create booking cancellation requests, trigger booking notification emails, and overwrite the content of the email...
EUVD-2026-101839
The The Ocean Extra plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.6.0 This is due to the software allowing users to execute an action that does not properly validate a value before running doshortcode. This makes it possible for...
EUVD-2026-101747
Better Auth from 1.5.0-beta.12 before 1.7.7 contains an authentication bypass vulnerability in the OAuth Proxy plugin that allows unauthenticated attackers to sign in as other users by forging encrypted profiles. When the proxy shares the global secret and cookie-stored state is used, attackers c...
ALSA-2026:83544 Important: grafana security update
Grafana is an open source, feature rich metrics dashboard and graph editor for Graphite, InfluxDB & OpenTSDB. Security Fixes: grafana: PLUGIN ARCHIVE EXTRACTION ESCAPES THE PLUGIN DIRECTORY, ALLOWING CODE EXECUTION CVE-2026-15815 For more details about the security issues, including the impact, a...
grafana security update
9.2.10-35.0.1 - Fixes CVE-2024-1442 Add email verification when updating user email Orabug: 38550520 9.2.10-35 - CVE-2026-15815 grafana: PLUGIN ARCHIVE EXTRACTION ESCAPES THE PLUGIN DIRECTORY, ALLOWING CODE EXECUTION - Resolves RHEL-253157 9.2.10-34 - CVE-2026-42504 grafana: Golang MIME: Denial o...
PT-2026-114779
The Mang Board WP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'data type' parameter in all versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web...