814 matches found
CVE-2026-102463
Eclipse Vert.x versions [4.0.0, 4.5.34], [5.0.0, 5.0.12], [5.1.0, 5.1.9], and [5.2.0, 5.2.0] are vulnerable in the vertx-pg-client component. The DataTypeCodec.binaryDecodeArray function fails to enforce an upper bound on the 32-bit dimension count provided by a PostgreSQL server during binary ar...
CVE-2026-102463
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the binary array decoder in vertx-pg-client DataTypeCodec.binaryDecodeArray allocates a Java array sized by a server-declared 32-bit dimension count with no upper bound. A malicious or compromised PostgreSQL...
ai.pipestream:connector-admin-service (0.1.18), ai.pipestream:pipestream-engine (0.0.6) +211 more potentially affected by CVE-2026-102463 via io.vertx:vertx-pg-client (>=4.0.0, <=4.5.34)
io.vertx:vertx-pg-client MAVEN version =4.0.0, =0.1.25, =0.0.1-v20250610200556, =0.0.10, =1.2, =0.3.1.2, =0.3.1.2, =0.6.0.0, =0.1.0, =0.1.0, =0.4.0.1, =0.8.3.0 and more Source cves: CVE-2026-102463 Source advisory: MEND:CVE-2026-102463...
CVE-2026-102463
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the binary array decoder in vertx-pg-client DataTypeCodec.binaryDecodeArray allocates a Java array sized by a server-declared 32-bit dimension count with no upper bound. A malicious or compromised PostgreSQL...
EUVD-2026-101958
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the binary array decoder in vertx-pg-client DataTypeCodec.binaryDecodeArray allocates a Java array sized by a server-declared 32-bit dimension count with no upper bound. A malicious or compromised PostgreSQL...
CVE-2026-102463
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the binary array decoder in vertx-pg-client DataTypeCodec.binaryDecodeArray allocates a Java array sized by a server-declared 32-bit dimension count with no upper bound. A malicious or compromised PostgreSQL...
CVE-2026-102463
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the binary array decoder in vertx-pg-client DataTypeCodec.binaryDecodeArray allocates a Java array sized by a server-declared 32-bit dimension count with no upper bound. A malicious or compromised PostgreSQL...
CVE-2026-103223: Memory Allocation with Excessive Size Value
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the PostgreSQL message decoder reads the 4-byte message length field from the PostgreSQL wire protocol without any maximum validation. A malicious, compromised, or man-in-the-middle PostgreSQL server can send...
PT-2026-114829
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the binary array decoder in vertx-pg-client DataTypeCodec.binaryDecodeArray allocates a Java array sized by a server-declared 32-bit dimension count with no upper bound. A malicious or compromised PostgreSQL...
PT-2026-114834
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the PostgreSQL message decoder reads the 4-byte message length field from the PostgreSQL wire protocol without any maximum validation. A malicious, compromised, or man-in-the-middle PostgreSQL server can send...
CVE-2026-102463: Memory Allocation with Excessive Size Value
In Eclipse Vert.x versions 4.0.0, 4.5.34 or 5.0.0,5.0.12 or 5.1.0,5.1.9 or 5.2.0, 5.2.0, the binary array decoder in vertx-pg-client DataTypeCodec.binaryDecodeArray allocates a Java array sized by a server-declared 32-bit dimension count with no upper bound. A malicious or compromised PostgreSQL...
0perator (>=0.1.0, <=0.3.0), 0pflow (>=0.1.0-dev.00aaa03, <=0.1.0) +3334 more potentially affected by CVE-2026-104872 via @opentelemetry/instrumentation-pg (>=0.15.0, <=0.72.0)
@opentelemetry/instrumentation-pg NPM version =0.15.0, =0.1.0, =0.1.0-dev.00aaa03, =0.0.1, =3.11.1, =0.0.53, =0.0.31, =0.8.0, =0.1.0, =1.0.5, =0.0.0-dev-nicolas-fix-publishing-aurora-mcp-1750279939, =0.3.702, =0.0.65, =0.2.0, =0.2.0, =0.2.6 and more Source cves: CVE-2026-104872 Source advisory:...
0perator (>=0.1.0, <=0.3.0), 0pflow (>=0.1.0-dev.00aaa03, <=0.1.0) +3334 more potentially affected by CVE-2026-104872 via @opentelemetry/instrumentation-pg (>=0.15.0, <=0.72.0)
@opentelemetry/instrumentation-pg NPM version =0.15.0, =0.1.0, =0.1.0-dev.00aaa03, =0.0.1, =3.11.1, =0.0.53, =0.0.31, =0.8.0, =0.1.0, =1.0.5, =0.0.0-dev-nicolas-fix-publishing-aurora-mcp-1750279939, =0.3.702, =0.0.65, =0.2.0, =0.2.0, =0.2.6 and more Source cves: CVE-2026-104872 Source advisory:...
Multiple @opentelemetry/instrumentation-* packages expose database username via unconditional db.user span attribute
Impact Multiple @opentelemetry/instrumentation- packages recorded the database connection username as the db.user span attribute on every instrumented database operation. This attribute was emitted unconditionally — it was not gated by enhancedDatabaseReporting or any other opt-in flag, and it wa...
0perator (>=0.1.0, <=0.3.0), 0pflow (>=0.1.0-dev.00aaa03, <=0.1.0) +3334 more potentially affected by CVE-2026-104872 via @opentelemetry/instrumentation-pg (>=0.15.0, <=0.72.0)
@opentelemetry/instrumentation-pg NPM version =0.15.0, =0.1.0, =0.1.0-dev.00aaa03, =0.0.1, =3.11.1, =0.0.53, =0.0.31, =0.8.0, =0.1.0, =1.0.5, =0.0.0-dev-nicolas-fix-publishing-aurora-mcp-1750279939, =0.3.702, =0.0.65, =0.2.0, =0.2.0, =0.2.6 and more Source cves: CVE-2026-104872 Source advisory:...
PT-2026-104440
Name of the Vulnerable Software and Affected Versions postgresql-operator charm versions prior to 1189 arm64 and 1190 amd64 in the dev track 14/edge postgresql-operator charm versions prior to 1216 arm64 and 1217 amd64 in the stable track 14/stable Description The postgresql-operator charm utiliz...
ruby:4.0 security update
ruby 4.0.6-35 - Fix resolv: do not register on-demand classes for unknown DNS types and SvcParamKeys to prevent memory exhaustion CVE-2026-80212 Resolves: RHEL-252035 4.0.6-34 - Upgrade to Ruby 4.0.6. Resolves: RHEL-211301 Resolves: RHEL-193663 4.0.3-33 - Fix Net::IMAP ResponseReader quadratic...
ruby:4.0 security update
An update is available for rubygem-pg, ruby, module.rubygem-pg, module.ruby, module.rubygem-mysql2, rubygem-mysql2. This update affects Rocky Linux 9. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability from the CVE li...
ruby:3.3 security update
An update is available for rubygem-pg, ruby, module.rubygem-pg, module.rubygem-abrt, module.ruby, module.rubygem-mysql2, rubygem-abrt, rubygem-mysql2. This update affects Rocky Linux 8. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for...
PT-2026-99913
WarehousePG WHPG 7.x before 7.6.0-WHPG is affected by a missing authorization vulnerability CWE-862 in the built-in server-side file functions pg file writetext,text,bool, pg file renametext,text,text, pg file unlinktext, and pg logdir ls. These functions are executable by any authenticated...