69 matches found
santoku (>=200902.10.0, <=201111.17.0) potentially affected by CVE-2024-21272 via mysql-connector-python (8.0.5)
mysql-connector-python PYPI version 8.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - santoku =200902.10.0, =201111.17.0 Source cves: CVE-2024-21272 Source advisory: OSV:PYSEC-2026-1685...
PYSEC-2026-1685 MySQL Connector/Python connector takeover vulnerability
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.0.0 and prior. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors...
MySQL Connector/Python connector takeover vulnerability
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.0.0 and prior. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors...
agixt (>=1.4.20, <=1.4.42), bepatient-db (0.4.0) +13 more potentially affected by CVE-2024-21272 via mysql-connector-python (8.1.0)
mysql-connector-python PYPI version 8.1.0 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - agixt =1.4.20, =0.0.107, =0.0.2, =0.0.3, =0.0.1, =1.0.0, =0.1.0, =0.4.3, =0.0.1, =0.0.0, =0.0.7 - wolf-core 2.0.1...
santoku (>=200902.10.0, <=201111.17.0) potentially affected by CVE-2019-2435 via mysql-connector-python (8.0.5)
mysql-connector-python PYPI version 8.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - santoku =200902.10.0, =201111.17.0 Source cves: CVE-2019-2435 Source advisory: OSV:PYSEC-2026-683...
Improper Access Control in MySQL Connector Python
Vulnerability in the MySQL Connectors component of Oracle MySQL subcomponent: Connector/Python. Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connector...
PYSEC-2026-683 Improper Access Control in MySQL Connector Python
Vulnerability in the MySQL Connectors component of Oracle MySQL subcomponent: Connector/Python. Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connector...
FreeBSD : py-mysql-connector-python -- Vulnerability in the MySQL Connectors product of Oracle MySQL (cb570d6f-9ea9-11f0-9446-f02f7497ecda)
The version of FreeBSD installed on the remote host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the cb570d6f-9ea9-11f0-9446-f02f7497ecda advisory. Oracle reports: Vulnerability in the MySQL Connectors product of Oracle MySQL component:...
Linux Distros Unpatched Vulnerability : CVE-2024-21090
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 8.3.0 and prior. Easily...
Linux Distros Unpatched Vulnerability : CVE-2024-21272
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.0.0 and prior. Difficult t...
UBUNTU-CVE-2025-30714
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.0.0-9.2.0. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful...
CVE-2025-30714
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.0.0-9.2.0. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful...
adstoolbox (>=1.0.29, <=2025.9.5), afw (>=0.0.6, <=0.0.21) +42 more potentially affected by CVE-2025-30714 via mysql-connector-python (>=9.0.0, <=9.2.0)
mysql-connector-python PYPI version =9.0.0, =1.0.29, =0.0.6, =1.7.0, =1.0.6, =0.5.0, =0.2.1, =1.0.1, =0.1.20, =1.107.2rc3, =0.1.0, =0.8.0, =1.0.3, =0.1.0.dev431, =1.2.3 and more Source cves: CVE-2025-30714 Source advisory: SNYK:PYTHON-MYSQLCONNECTORPYTHON-9724724...
openSUSE 15 Security Update : python-mysql-connector-python (openSUSE-SU-2024:0351-1)
The remote openSUSE 15 host has a package installed that is affected by a vulnerability as referenced in the openSUSE- SU-2024:0351-1 advisory. - Update to 9.1.0 boo1231740, CVE-2024-21272 - WL16452: Bundle all installable authentication plugins when building the C-extension - WL16444: Drop build...
SQL Injection
Overview mysql-connector-python is a MySQL driver written in Python which does not depend on MySQL C client libraries and implements the DB API v2.0 specification PEP-249. Affected versions of this package are vulnerable to SQL Injection due to improper sanitization of schema and table names...
santoku (>=200902.10.0, <=201111.17.0) potentially affected by unknown CVE via mysql-connector-python (8.0.5)
mysql-connector-python PYPI version 8.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - santoku =200902.10.0, =201111.17.0 Source cves: unknown CVE Source advisory: SNYK:PYTHON-MYSQLCONNECTORPYTHON-832093...
blackline-mysql (>=0.1.0a0, <=0.1.2), csv-db-loader (1.0.0) +6 more potentially affected by CVE-2024-21272 via mysql-connector-python (8.0.32)
mysql-connector-python PYPI version 8.0.32 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - blackline-mysql =0.1.0a0, =0.0.1, =0.0.1, =0.0.3, =0.80.0, =0.3.8, =0.3.18 Source cves: CVE-2024-21272 Source...
burgos (>=0.0.4, <=2.2.1), configops (>=0.1.5, <=0.2.3) +3 more potentially affected by CVE-2024-21272 via mysql-connector-python (8.0.30)
mysql-connector-python PYPI version 8.0.30 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - burgos =0.0.4, =0.1.5, =3.0.4, =3.5.6 - wwdtm 2.0.7 Source cves: CVE-2024-21272 Source advisory:...
allsql (>=0.0.1, <=0.0.5), bribrain (>=1.0.3, <=1.3.6) +5 more potentially affected by CVE-2024-21272 via mysql-connector-python (8.0.28)
mysql-connector-python PYPI version 8.0.28 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - allsql =0.0.1, =1.0.3, =0.3.0, =0.0.6, =1.0.1, =2.0.0rc3, =2.0.5 Source cves: CVE-2024-21272 Source advisory:...
botsislabutils (1.0.0), pxtextmining (>=0.2.5, <=0.4.2) +1 more potentially affected by CVE-2024-21272 via mysql-connector-python (8.0.23)
mysql-connector-python PYPI version 8.0.23 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - botsislabutils 1.0.0 - pxtextmining =0.2.5, =0.4.2 - tweetle 1.0.1 Source cves: CVE-2024-21272 Source advisory:...