10771 matches found
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
s3tk
s3tk A security toolkit for Amazon S3 🍊 Battle-tested at Instacart Installation Run: pip install s3tk You can use the AWS CLI or AWS Vault to set up your AWS credentials: pip install awscli aws configure See IAM policies needed for each command. Commands Scan Scan your buckets for: ACL open to...
metasploitable3
Metasploitable3 Metasploitable3 is a VM that is built from the ground up with a large amount of security vulnerabilities. It is intended to be used as a target for testing exploits with metasploit. Metasploitable3 is released under a BSD-style license. See COPYING for more details. Quick-start To...
Ghost-In-The-Logs
Ghost In The Logs This tool allows you to evade sysmon and windows event logging, my blog post about it can be found here Usage You can grab the lastest release here Starting off Once you've got the latest version execute it with no arguments to see the avalible commands $ gitl.exe Loading the ho...
Winshark
Winshark Wireshark plugin to work with Event Tracing for Windows Microsoft Message Analyzer is being retired and its download packages were removed from microsoft.com sites on November 25 2019. Wireshark have built a huge library of network protocol dissectors. The best tool for Windows would be...
Stracciatella
Stracciatella v0.7 Powershell runspace from within C aka SharpPick technique with AMSI, ETW and Script Block Logging disabled for your pleasure. Nowadays, when Powershell got severly instrumented by use of techniques such as: AMSI ETW Script Block Logging Transcript file Modules logging Constrain...
log4j2
log4j2 this is a log4j2 jmi attack demo, inspired by link...
DrMITM
D̳r̳M̳I̳T̳M̳ DrMITM is a program designed to globally log all traffic. Diagram: H̳o̳w̳ i̳t̳ w̳o̳r̳k̳s̳ DrMITM sends a request to website and returns the IP of the website just in case the server of the website is designed to rely on the website IP for requests, and the request that goes to the...
cirro
Cirro is an extensible security research platform that enables researchers and penetration testers to collect, analyze, and visualize cloud environments and identity relationships through graph databases. Built with a modular architecture, Cirro can be extended to support multiple platforms and...
scopeblind-gateway
⚠️ This repository has moved. Active development continues at ScopeBlind/scopeblind-gateway. This personal fork may be behind the canonical repository. Please use the org repo for issues, pull requests, and the latest code. protect-mcp Security gateway for MCP servers. Shadow-mode logs by default,...
agentwatch
agentwatch A flight recorder for Claude Code sessions. You let Claude Code run on your machine — sometimes for hours, sometimes with auto-approve. agentwatch silently logs every action, so you can come back and see exactly what happened. npm install -g agentwatch-dev agentwatch install That's it...
h0neytr4p
Adjusted for T-Pot This fork of h0neytr4p was revised for T-Pot with the following features: Add Docker support Dockerfile, docker-compose.yml Use a single logfile instead of two Log to JSON instead of CSV Enrich JSON log file with additional info i.e. Cookies, Headers, Destination Port, etc...
cowitness
CoWitness CoWitness is a tool designed to function as an HTTP, HTTPS, and DNS server. It allows you to serve web pages, log HTTP requests, and customize DNS responses. This README provides an overview of the features and instructions on how to compile and use the CoWitness tool. Features HTTP...
CVE-2020-2978
CVE-2020-2978 CVE-2020-2978 refrence link for PoC: https://databasesecurityninja.wordpress.com/2020/12/01/cve-2020-2978-rman-audit-table-point-in-time-recovery-not-logged/...
SSOh-No
SSOh-No This tool is designed to enumerate users, password spray and perform brute force attacks against any organisation that utilises Azure AD or O365. Generally, this endpoint provides extremely verbose errors which can be leveraged to enumerate users and validate their passwords via brute...
LID
██╗ ██╗██████╗ ██║ ██║██╔══██╗ ██║ ██║██║ ██║ ██║ ██║██║ ██║ ███████╗██║██████╔╝ ╚══════╝╚═╝╚═════╝ Linux Integrity Drift — "Linux is Dying" — Systematic discovery of kernel code paths that bypass LSM security guarantees The gate was never breached. It was walked around. What is LID? The Linux...
MrKaplan
Mr.Kaplan Description MrKaplan is a tool aimed to help red teamers to stay hidden by clearing evidence of execution. It works by saving information such as the time it ran, snapshot of files and associate each evidence to the related user. This tool is inspired by MoonWalk, a similar tool for Uni...
log-add-http-post-bodies
Add POST body excerpt to the HTTP log This script gives analysts the ability to peek into what is being sent in HTTP POST bodies. It provides this by simply extending the HTTP log. Installation :: zkg refresh zkg install corelight/log-add-http-post-bodies Usage The HTTP log will have a new field...
CVE-2023-32428-a-macOS-LPE-via-MallocStackLogging
CVE-2023-32428-a-macOS-LPE-via-MallocStackLogging...
chronix
Chronix Self-hosted collaborative workspace for pentesters and red team operators. Captures notes, commands, outputs, and operational context during security engagements. Quick Start Install pipx install git+https://github.com/IceCubeSandwich/chronix Initialize creates account and session secret...