9968 matches found
metasploitable3
Metasploitable3 Metasploitable3 is a VM that is built from the ground up with a large amount of security vulnerabilities. It is intended to be used as a target for testing exploits with metasploit. Metasploitable3 is released under a BSD-style license. See COPYING for more details. Quick-start To...
agentwatch
agentwatch 一个用于Claude Code会话的飞行记录器。 你让Claude Code在你的机器上运行——有时几小时,有时自动批准。agentwatch 静默记录每一个操作,这样你之后可以回来查看究竟发生了什么。 npm install -g agentwatch-dev agentwatch install 就这样。两个命令。agentwatch 现在正在记录每一个 Claude Code 会话。 你实际上会使用的命令 agentwatch last what just happened? agentwatch danger did anything risky happe...
Aker
Aker SSH 网关 什么是 Aker? Aker 是一款安全工具,可帮助您配置自己的 Linux SSH 跳板/堡垒主机。Aker 以埃及神话中守卫边境的神祇命名,将作为所有系统管理员和支持人员访问 Linux 生产服务器的唯一瓶颈。Aker SSH 网关包含众多安全功能,可帮助您轻松管理和运维数千台 Linux 服务器。详细说明请查阅我们的 Wiki 动机 我找不到类似 CryptoAuditor 和 fudo 的开源工具。这类工具对于需要满足 PCI-DSS 或 HIPAA...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
Empire
Empire Empire is a post-exploitation and adversary emulation framework that is used to aid Red Teams and Penetration Testers. The Empire server is written in Python 3 and is modular to allow operator flexibility. Empire comes built-in with a client that can be used remotely to access the server...
pgaudit
pgAudit Registro de Auditoría de Código Abierto para PostgreSQL Introducción La Extensión de Auditoría de PostgreSQL pgAudit proporciona un registro de auditoría detallado de sesión y/u objeto a través del sistema de registro estándar de PostgreSQL. El objetivo de pgAudit es ofrecer a los usuario...
frida
frida This repository contains various Frida scripts for Android application penetration testing. I created this project to demonstrate the capabilities of the Frida dynamic-analysis framework. You can read my "Introduction to Frida" blog post on Medium, where I'm explaining how to use Frida with...
react2shell-honeypot
React2Shell honeypot My attempt to make honeypot for React2Shell vulnerability All attack payloads are written to logs/ip folder Usage go build Optionally: export GINMODE=release react2shell-honeypot -addr localhost:8080 Tested on scanners: assetnote/react2shell-scanner...
AiSOC
AiSOC An open-source, self-hostable AI Security Operations Center. It ingests your security telemetry, detects and correlates threats, investigates them with AI agents whose reasoning is fully auditable, and proposes responses a human approves. Docs · Architecture · What actually works ·...
santa
Santa Santa is a binary and file access authorization system for macOS. It consists of a system extension that monitors for executions & file access, and makes decisions based on the contents of a local database, a GUI agent that notifies the user in case of a block decision, a background service...
Winshark
Winshark Wireshark 插件,用于处理 Windows 事件跟踪 Microsoft Message Analyzer 正在退役,其下载包已于 2019 年 11 月 25 日从 microsoft.com 网站移除。 Wireshark 已经构建了一个庞大的网络协议解析器库。 对于 Windows 而言,最好的工具应该是能够收集并混合所有类型日志的工具... 欢迎 Winshark!!! Winshark 基于 libpcap 后端来捕获 ETW(Windows 事件跟踪),并有一个生成器,可以为您的机器上已知的 ETW 提供程序生成所有解析器。 我们添加了...
java-log4j-cve-2020-9488
java-log4j-cve-2020-9488 CVE-2020-9488 的演示:使用 Log4j 进行不安全日志记录及修复...
LID
██╗ ██╗██████╗ ██║ ██║██╔══██╗ ██║ ██║██║ ██║ ██║ ██║██║ ██║ ███████╗██║██████╔╝ ╚══════╝╚═╝╚═════╝ Linux Integrity Drift — "Linux is Dying" — Systematic discovery of kernel code paths that bypass LSM security guarantees The gate was never breached. It was walked around. What is LID? The Linux...
penelope
Penelope is a modern shell handler for penetration testers and CTF players. It provides a more capable alternative to basic netcat listeners, adding automatic PTY upgrades, session management, logging, file transfers and helper modules. Table of Contents 📥 Installation ⚙️ Features 🖥️ Session...
processhacker-mcp
processhacker mcp este es un servidor mcp dinámico para análisis en tiempo de ejecución y hackeo de procesos. es como processhacker pero para agentes de ia. configuración 1. abre la carpeta en visual studio tiene cmakelists 2. compila todo ctrl+shift+b 3. genera ProcessHackerMCP.exe y la carpeta...
log-add-http-post-bodies
Añadir extracto del cuerpo POST al registro HTTP Este script brinda a los analistas la capacidad de ver lo que se envía en los cuerpos de las peticiones POST HTTP. Lo consigue simplemente ampliando el registro HTTP. Instalación :: zkg refresh zkg install corelight/log-add-http-post-bodies Uso El...
kippo
注意:对于更近期的开发,请查看 Michel Oosterhof 的分支 Kippo Kippo 是一个中等交互的 SSH 蜜罐,旨在记录暴力破解攻击,以及最重要的是,攻击者执行的全部 shell 交互。 Kippo 的灵感来源于,但并不基于 Kojoney。 演示 下面是一些来自运行中的 Kippo 安装的有趣日志(可通过 Ajaxterm 在网页浏览器中查看)。请注意,自这些日志记录以来,某些命令可能已得到改进。 2009-11-22 2009-11-23 2009-11-23 2010-03-16 功能特性 一些有趣的功能: 具有添加/删除文件能力的虚拟文件系统。包含一个模仿...
jackit
JackIt 喜欢JackIt但不想带着笔记本电脑?看看这个。 介绍 这是Bastille的MouseJack漏洞的部分实现。详细信息请参见mousejack.com。全部功劳归功于Bastille团队发现此问题并编写了与CrazyRadio PA无线网卡配合使用的库。同时感谢Samy Kamkar的KeySweeper,Thorsten Schroeder和Max Moser在KeyKeriki上的工作,以及Travis Goodspeed。我们是站在巨人的肩膀上。 我们已在以下硬件上测试成功: 微软无线键盘800(含击键记录) 微软无线鼠标1000 微软无线移动鼠标3500...
log4shell-mitigation
Details and Mitigation Strategy for log4j2 RCE Vulnerability Visit this Youtube video for additional details. https://youtu.be/jqWdwTeGRK0 This is a quick post on the mitigation for CVE-2021-44228 Security Vulnerability aka Log4Shell and LogJam found in log4j2 Disclaimer All the information and...