9966 matches found
log4j-shell-poc
log4j-shell-poc A Proof-Of-Concept for the recently found CVE-2021-44228 vulnerability. Recently there was a new vulnerability in log4j, a java logging library that is very widely used in the likes of elasticsearch, minecraft and numerous others. In this repository we have made and example...
chronix
Chronix Self-hosted collaborative workspace for pentesters and red team operators. Captures notes, commands, outputs, and operational context during security engagements. Quick Start Install pipx install git+https://github.com/IceCubeSandwich/chronix Initialize creates account and session secret...
wetland
Wetland Wetland is a high interaction SSH honeypot,designed to log brute force attacks.What's more, wetland will log shell、scp、sftp、exec-command、direct-forward、reverse-forward interation performded by the attacker. Wetland is based on python ssh module paramiko. And wetland runs as a...
s3tk
s3tk A security toolkit for Amazon S3 🍊 Battle-tested at Instacart Installation Run: pip install s3tk You can use the AWS CLI or AWS Vault to set up your AWS credentials: pip install awscli aws configure See IAM policies needed for each command. Commands Scan Scan your buckets for: ACL open to...
SteppingStones
Stepping Stones Purpose A hub for Red Team activity to aid in record keeping, situational awareness and reporting. Stepping Stones provides a web based UI for the team to log activity and generate report snippets. The UI is intended to be rapid enough to be used throughout the engagement, not jus...
Pentest-Mapper
Pentest Mapper Pentest Mapper is a Burp Suite extension that integrates the Burp Suite request logging with a custom application testing checklist. The extension provides a straightforward flow for application penetration testing. The extension includes functionalities to allow users to map the...
interactsh
An OOB interaction gathering server and client library Features • Usage • Interactsh Client • Interactsh Server • Interactsh Integration • Join Discord Interactsh is an open-source tool for detecting out-of-band interactions. It is a tool designed to detect vulnerabilities that cause external...
Pulse
Pulse is a powerful logging system for Apple Platforms. Native. Built with SwiftUI. Record and inspect logs and URLSession network requests right from your iOS app. Share logs and view them in Pulse Pro or use remote logging to see them in real time. Logs are stored locally and never leave your...
Keylogger
Inputs To Mail. Get Keyboard,Mouse,ScreenShot,Microphone Inputs and Send to your Mail. Purpose of the project is testing the security of information systems INSTALLATION You don't need to do anything for installation just run the script USAGE •Create an account on "https://mailtrap.io/" using a...
CVE-2026-59827
Authorized Metabase CVE-2026-59827 Penetration Testing Tool An authorized security assessment utility for validating the presence of CVE-2026-59827 in Metabase deployments during approved penetration testing engagements. This tool is designed to demonstrate the existence of the vulnerability whil...
bofhound
THIS REPO IS NO LONGER ACTIVE ⛔🚧 This repo is no longer maintained. To submit an issue, pull request, or obtain the lastest version, reference https://github.com/coffeegist/bofhound 🚧⛔ | / / / | /| | | | / \ | | | | | \ | | | \ | | | | | | | | | | || | | | | | | | | | | | | | .--. | | | | | | | |...
Suborner
Suborner: The Invisible Account Forger What's this? A simple program to create a Windows account you will only know about : Create invisible local accounts without net user or Windows OS user management applications e.g. netapi32::netuseradd Works on all Windows NT Machines Windows XP to 11,...
kerbrute
Kerbrute A tool to quickly bruteforce and enumerate valid Active Directory accounts through Kerberos Pre-Authentication Grab the latest binaries from the releases page to get started. Background This tool grew out of some bash scripts I wrote a few years ago to perform bruteforcing using the...
attack_range
Splunk Attack Range v5 The Splunk Attack Range builds instrumented cloud environments AWS, Azure, GCP, simulates attacks, and forwards data into Splunk for detection development and testing. What it does: Build labs — Deploy a small, production-like lab Splunk, Windows/Linux servers, optional Kal...
metasploitable3
Metasploitable3 Metasploitable3 is a VM that is built from the ground up with a large amount of security vulnerabilities. It is intended to be used as a target for testing exploits with metasploit. Metasploitable3 is released under a BSD-style license. See COPYING for more details. Quick-start To...
agentwatch
agentwatch A flight recorder for Claude Code sessions. You let Claude Code run on your machine — sometimes for hours, sometimes with auto-approve. agentwatch silently logs every action, so you can come back and see exactly what happened. npm install -g agentwatch-dev agentwatch install That's it...
Aker
Aker SSH Gateway What is Aker? Aker is a security tool that helps you configure your own Linux ssh jump/bastion host. Named after an Egyptian mythology deity who guarded the borders, Aker would act as choke point through which all your sysadmins and support staff access Linux production servers...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
Empire
Empire Empire is a post-exploitation and adversary emulation framework that is used to aid Red Teams and Penetration Testers. The Empire server is written in Python 3 and is modular to allow operator flexibility. Empire comes built-in with a client that can be used remotely to access the server...
pgaudit
pgAudit Open Source PostgreSQL Audit Logging Introduction The PostgreSQL Audit Extension pgAudit provides detailed session and/or object audit logging via the standard PostgreSQL logging facility. The goal of pgAudit is to provide PostgreSQL users with capability to produce audit logs often...