212840 matches found
Astra Linux – Vulnerability in WebKit2GTK
A memory corruption issue has been resolved through improved input validation. This issue is fixed in Safari 16.2, tvOS 16.2, macOS Ventura 13.1, iOS 15.7.2 and iPadOS 15.7.2, iOS 16.2 and iPadOS 16.2, watchOS 9.2. Processing maliciously crafted web content may lead to arbitrary code execution...
Astra Linux – Vulnerability in libslirp
An invalid pointer initialization issue was discovered in the SLiRP networking implementation of QEMU. The flaw resides in the tftpinput function and can occur when processing an UDP packet that is smaller than the size of the ‘tftpt’ structure. This issue may lead to out-of-bounds read access or...
Astra Linux – Vulnerability in LibreOffice
There is a vulnerability in input validation in the GStreamer integration of The Document Foundation LibreOffice, which allows an attacker to execute arbitrary GStreamer plugins. In affected versions, the filename of the embedded video is not properly escaped when passed to GStreamer, enabling an...
Astra Linux – Vulnerability in Linux 5.15
In the Linux kernel, the following vulnerability has been resolved: iio: fixed a memory leak in iiodeviceregistereventset When iiodeviceregistersysfsgroup returns an error, iiodeviceregistereventset must free the attrs array. Otherwise, kmemleak will detect and report a memory leak as follows:...
Astra Linux – Vulnerability in CGal
There are multiple code execution vulnerabilities in the Nef polygon-parsing functionality of CGAL libcgal CGAL-5.1.1. A specially crafted malformed file can lead to an out-of-bounds read and type confusion, which could result in code execution. An attacker can provide malicious input to trigger...
Astra Linux – Vulnerability in CGal
There are multiple code execution vulnerabilities in the Nef polygon-parsing functionality of CGAL libcgal CGAL-5.1.1. A specially crafted malformed file can lead to an out-of-bounds read and type confusion, which could result in code execution. An attacker can provide malicious input to trigger...
Astra Linux – Vulnerability in pyyaml
A vulnerability was discovered in the PyYAML library in versions prior to 5.3.1. In these versions, the library is susceptible to arbitrary code execution when it processes untrusted YAML files using the fullload method or the FullLoader loader. Applications that use this library to process...
Astra Linux – Vulnerability in OpenSSL
Issue summary: Checking excessively long DH keys or parameters can be very slow. Applications that use functions such as DHcheck, DHcheckex, or EVPPKEYparamcheck to check DH keys or parameters may experience prolonged delays. If the keys or parameters being checked were obtained from an untrusted...
Astra Linux – Vulnerability in node-cipher-base
There is a vulnerability in improper input validation in the cipher-base module, which allows for manipulation of input data. This issue affects cipher-base version 1.0.4...
Astra Linux - Vulnerability in node-sha.js
There is a vulnerability in input validation in sha.js that allows for manipulation of input data. This issue affects sha.js version 2.4.11...
Astra Linux – Vulnerability in libmysofa
Incorrect handling of input data in the mysofaresamplerresetmem function in the libmysofa library between versions 0.5 and 1.1 may lead to heap buffer overflow and overwriting of a large memory block...
Astra Linux – Vulnerability in Tomcat9
The simplified implementation of blocking reads and writes introduced in Tomcat 10, and backported to Tomcat 9.0.47 and later versions, exposed a long-standing but extremely difficult to trigger concurrency bug in Apache Tomcat 10.1.0 to 10.1.0-M12, 10.0.0-M1 to 10.0.18, 9.0.0-M1 to 9.0.60, and...
Astra Linux – Vulnerability in libxstream-java
XStream is a simple library for serializing objects to XML and back again. In affected versions, this vulnerability may allow a remote attacker to load and execute arbitrary code from a remote host by manipulating the processed input stream. No users are affected if they follow the recommendation...
Astra Linux – Vulnerability in exiv2
There is a floating-point exception in the Exiv2::ValueType function in Exiv2 0.26, which can lead to a remote denial-of-service attack due to malicious input...
Astra Linux – Vulnerability in the 389-DS-base
The fix for CVE-2024-2199 in 389-ds-base was insufficient to cover all scenarios. In certain product versions, an authenticated user may cause a server crash while modifying userPassword using malformed input...
Astra Linux – Vulnerability in jq
jq is a command-line JSON processor. Prior to version 1.8.2, comparing two sufficiently deeply nested arrays using the “==” operator would exhaust the C stack on jq’s ordinary command-line interface, resulting in a denial-of-service attack due to stack exhaustion uncontrolled recursion. The crash...
Astra Linux – Vulnerability in Linux
In hidinputchangeresolutionmultipliers of hid-input.c, there is a possible out-of-bounds write due to a heap buffer overflow. This could lead to a local privilege escalation without the need for additional execution privileges. User interaction is not required for exploitation. Product: Android...
Astra Linux – Vulnerability in Chromium
Insufficient validation of untrusted input in the “File” feature in Google Chrome on Android prior to version 103.0.5060.134 allowed an attacker who convinced a user to install a malicious app to obtain potentially sensitive information from internal file directories via a crafted HTML page...
Astra Linux – Vulnerability in Bison
GNU Bison before version 3.5.4 allowed attackers to cause a denial of service application crash. NOTE: There is only a risk if Bison is used with untrusted inputs, and a reported bug could lead to unsafe behavior with a specific compiler/architecture. The bug reports were intended to indicate tha...
Astra Linux – Vulnerability in Ruby-Nokogiri
A command injection vulnerability exists in Nokogiri v1.10.3 and earlier. This vulnerability allows commands to be executed in a subprocess via Ruby’s Kernel.open method. Processes become vulnerable only if the undocumented method Nokogiri::CSS::Tokenizerloadfile is called with unsafe user input ...