211815 matches found
snapchange
Snapchange Lightweight fuzzing of a memory snapshot using KVM Snapchange provides the ability to load a raw memory dump and register state into a KVM virtual machine VM for execution. At a point in execution, this VM can be reset to its initial state by resetting the dirty pages found by KVM or...
CVE-2022-0739
CVE-2022-0739 BookingPress 1.0.11 - Unauthenticated SQL Injection The plugin fails to properly sanitize user supplied POST data before it is used in a dynamically constructed SQL query via the bookingpressfrontgetcategoryservices AJAX action available to unauthenticated users, leading to an...
CVE-2025-46178
CVE-2025-46178 Cross-Site Scripting XSS vulnerability exists in askquery.php via the eid parameter in the CloudClassroom PHP Project. This allows remote attackers to inject arbitrary JavaScript in the context of a victim s browser session by sending a crafted URL, leading to session hijacking or...
Hipcam-RTSP-Format-Validation-Vulnerability
Hipcam RealServer/V1.0 RTSP Format Validation Vulnerability Proof-of-Concept | CVE-2023-50685 Proof-of-Concept for RTSP Service Format Validation Vulnerability in Hipcam RealServer/V1.0. Description This POC exploits a format validation vulnerability in the Real Time Streaming Protocol RTSP servi...
naabu
Features • Installation • Usage • Running naabu • Config • NMAP integration • CDN/WAF Exclusion • Discord Naabu is a port scanning tool written in Go that allows you to enumerate valid ports for hosts in a fast and reliable manner. It is a really simple tool that does fast SYN/CONNECT/UDP scans o...
CVE-2021-21234
CVE-2021-21234 CVE-2021-21234 Spring Boot Directory Traversal spring-boot-actuator-logview adds a simple log file viewer as a spring boot actuator endpoint in a library. It is the maven package "eu.hinsch:spring-boot-actuator-logview". A directory traversal vulnerability exists in...
tetsuo-pulse
Socket Library Maturity Notice : This library is functional and well-tested but newly released. It is appropriate for development, internal tooling, and controlled environments. Production deployment with untrusted network input should wait until the codebase has accumulated several months of...
polyshell
PolyShell: a Bash/Batch/PowerShell polyglot What It Is PolyShell is a script that's simultaneously valid in Bash, Windows Batch, and PowerShell i.e. a polyglot. This makes PolyShell a useful template for penetration testing as it can be executed on most systems without the need for target-specifi...
CVE-2023-32692-CodeIgniter4
CVE-2023-32692 — CodeIgniter 4 Validation Rule Injection CVE-2023-32692 is a code injection vulnerability in the CodeIgniter 4 PHP framework, affecting versions 4.0.0 through 4.3.4. It was fixed in 4.3.5 released June 2023. This is a demo environment for anyone that wants to play with it...
CVE-2025-54123-Poc
CVE-2025-54123 Exploit Hoverfly Authenticated Middleware Command Injection RCE | CVSS 9.8 CRITICAL Vulnerability Hoverfly -u -p -c --shell SHELL -t, --target - Hoverfly API endpoint required -u, --username - Admin username required -p, --password - Admin password required -c, --command -...
CVE-2026-34835-Black-box-Analysis
This repository provides a black-box security analysis of CVE-2026-34835 from the perspective of an external penetration tester. The objective is not to reverse engineer the vulnerability, but to document how a security assessor can identify, validate, and evaluate its impact during an authorized...
CVE-2024-36401-GeoServer-RCE
RCE vulnerability in GeoServer CVE-2024-36401 - detection script CVE-2024-36401 is a critical security vulnerability affecting GeoServer, an open-source server for sharing geospatial data, and GeoTools, an open-source Java library that provides tools for geospatial data. The vulnerability,...
MassExploit-CVE-2024-4577
CVE-2024-4577 Mass Scanner & Exploit Tool This Python script automates the detection of servers vulnerable to CVE-2024-4577 , a critical vulnerability in PHP-CGI that allows remote code execution RCE through specially crafted query parameters. The tool sends a PHP payload using...
CVE-2023-34840
CVE-2023-34840 Vulnerability Explanation All versions in angular-ui-notification are vulnerable to XSS due to the library not sanitizing the input provided by the user. In order to safely use this library, sanitizing / encoding the parameters passed to this library is highly recommended, such as...
CVE-2018-7600-PoC
SAWPOC — CVE-2018-7600 A Python Proof of Concept for CVE-2018-7600 , also known as Drupalgeddon2. CVE-2018-7600 is a critical vulnerability affecting certain versions of Drupal 7. Under vulnerable configurations, an unauthenticated attacker may be able to inject malicious input and achieve remote...
EITS-Portal-Exploit-CVE-2026-31367-PoC
💥 CVE-2026-31367: EITS Admin Dashboard v2.4.0 - RCE PoC This repository contains the Proof of Concept PoC for the unauthenticated Remote Code Execution RCE vulnerability in EITS Admin Dashboard v2.4.0 CVE-2026-31367. The vulnerability occurs due to a flaw in input sanitization on the /api/v1/debu...
recollapse
REcollapse REcollapse is a helper tool for black-box regex fuzzing to bypass validations and discover normalizations in web applications. It can also be helpful to bypass WAFs and weak vulnerability mitigations. For more information, take a look at the REcollapse blog post. The goal of this tool ...
CVE-2025-55888
CVE-2025-55888 Description Cross-Site Scripting XSS vulnerability was discovered in the Ajax transaction manager endpoint of ARD. An attacker can intercept the Ajax response and inject malicious JavaScript into the accountName field. This input is not properly sanitized or encoded when rendered,...
PHPUnit_eval-stdin_RCE
PHPUniteval-stdinRCE CVE-2017-9841 PHPUniteval-stdinphp Remote Code Execution A code injection vulnerability in PHPUnit, a PHP unit testing framework which part of the Mailchimp , Mailchimp E-Commerce moduels in Drupal The vulnerability within the /phpunit/src/Util/PHP/eval-stdin.php file through...
-CVE-2024-21683-RCE-in-Confluence-Data-Center-and-Server
-CVE-2024-21683-RCE-in-Confluence-Data-Center-and-Server This vulnerability allows an unauthenticated attacker to remotely execute arbitrary code on a vulnerable Confluence server. The vulnerability exists due to an improper validation of user-supplied input in the Confluence REST API. This allow...