12 matches found
SUSE CVE-2017-9787
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33...
Apache Struts 2.3.x < 2.3.33 Denial of Service (S2-049)
The version of Apache Struts running on the remote host is 2.3.x prior to 2.3.33. It is, therefore, affected by the following vulnerability: - A flaw exists in unspecified Spring AOP functionality that is used to secure Struts actions. An authenticated, remote attacker can exploit this to cause a...
com.amashchenko.struts2.actionflow:struts2-actionflow-plugin (>=1.5.3, <=2.4.0), com.amashchenko.struts2.actionflow:struts2-actionflow-showcase (>=1.5.3, <=2.4.0) +187 more potentially affected by CVE-2017-9787 via org.apache.struts:struts2-core (>=2.3.7, <=2.3.32)
org.apache.struts:struts2-core MAVEN version =2.3.7, =1.5.3, =1.5.3, =1.2.2, =1.2.2, =1.2.2, =1.2.2, =1.0, =1.0, =1.0, =1.0, =2.0.0, =0.5.9, =1.2.0, =1.0.0, =1.2.6 and more Source cves: CVE-2017-9787 Source advisory: GHSA-8MR5-H28G-36QX...
com.amashchenko.struts2.pdfstream:struts2-pdfstream-plugin (2.0.0), com.amashchenko.struts2.pdfstream:struts2-pdfstream-showcase (2.0.0) +94 more potentially affected by CVE-2017-9787 via org.apache.struts:struts2-core (>=2.5, <=2.5.10.1)
org.apache.struts:struts2-core MAVEN version =2.5, =1.0.0-release, =2.5.0, =2.5.0, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.2 and more Source cves: CVE-2017-9787 Source advisory: GHSA-8MR5-H28G-36QXhttp...
com.amashchenko.struts2.actionflow:struts2-actionflow-plugin (>=1.5.3, <=2.4.0), com.amashchenko.struts2.actionflow:struts2-actionflow-showcase (>=1.5.3, <=2.4.0) +187 more potentially affected by CVE-2017-9787 via org.apache.struts:struts2-core (>=2.3.7, <=2.3.32)
org.apache.struts:struts2-core MAVEN version =2.3.7, =1.5.3, =1.5.3, =1.2.2, =1.2.2, =1.2.2, =1.2.2, =1.0, =1.0, =1.0, =1.0, =2.0.0, =0.5.9, =1.2.0, =1.0.0, =1.2.6 and more Source cves: CVE-2017-9787 Source advisory: OSV:GHSA-8MR5-H28G-36QX...
com.amashchenko.struts2.pdfstream:struts2-pdfstream-plugin (2.0.0), com.amashchenko.struts2.pdfstream:struts2-pdfstream-showcase (2.0.0) +94 more potentially affected by CVE-2017-9787 via org.apache.struts:struts2-core (>=2.5, <=2.5.10.1)
org.apache.struts:struts2-core MAVEN version =2.5, =1.0.0-release, =2.5.0, =2.5.0, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.2 and more Source cves: CVE-2017-9787 Source advisory: OSV:GHSA-8MR5-H28G-36QX...
Oracle WebLogic Server Multiple Vulnerabilities
Binary data oracleweblogicserverCVE-2017-9805.nbin...
CVE-2017-9787
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33...
CVE-2017-9787
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33...
CVE-2017-9787
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33...
com.amashchenko.struts2.actionflow:struts2-actionflow-plugin (>=1.5.3, <=2.4.0), com.amashchenko.struts2.actionflow:struts2-actionflow-showcase (>=1.5.3, <=2.4.0) +187 more potentially affected by CVE-2017-9787 via org.apache.struts:struts2-core (>=2.3.7, <=2.3.32)
org.apache.struts:struts2-core MAVEN version =2.3.7, =1.5.3, =1.5.3, =1.2.2, =1.2.2, =1.2.2, =1.2.2, =1.0, =1.0, =1.0, =1.0, =2.0.0, =0.5.9, =1.2.0, =1.0.0, =1.2.6 and more Source cves: CVE-2017-9787 Source advisory: MEND:CVE-2017-9787...
com.amashchenko.struts2.pdfstream:struts2-pdfstream-plugin (2.0.0), com.amashchenko.struts2.pdfstream:struts2-pdfstream-showcase (2.0.0) +94 more potentially affected by CVE-2017-9787 via org.apache.struts:struts2-core (>=2.5, <=2.5.10.1)
org.apache.struts:struts2-core MAVEN version =2.5, =1.0.0-release, =2.5.0, =2.5.0, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.1, =4.0.2 and more Source cves: CVE-2017-9787 Source advisory: MEND:CVE-2017-9787https...